Ask Your Question
0

Unable to configure touchpad in F22

asked 2015-06-07 18:41:16 -0500

mattingly890 gravatar image

I just did a fresh install of the KDE 5 spin of Fedora 22 on my laptop (Lenovo Thinkpad E440). Everything looks great, except that most of the touchpad configuration options are disabled.

In Fedora 21, I was able to use the KDE 4 dialogs to configure my touchpad to my liking, but the same dialogs appear to be disabled in KDE 5 on Fedora 22.

How do I reenable these options on Fedora 22 + KDE 5?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-15 17:57:28 -0500

whot gravatar image

Short answer: We've switched the default touchpad driver from xorg-x11-drv-synaptics to xorg-x11-drv-libinput and that has different configuration settings.

Longer answer: libinput exposes a subset of the options synaptics used to expose, but we do try to expose those we consider useful (e.g. you can enable tapping, but you can't change the button mapping for taps). So if you have a specific configuration requirement please file a bug against libinput and outline what you need (and the use-case for it).

The other intermediate option is to fall back to the synaptics driver for your touchpad. That is still around, at least until F24 anyway. Copy or symlink /usr/share/X11/xorg.conf.d/50-synaptics.conf into /etc/X11/xorg.conf.d/99-synaptics.conf and that will override the libinput driver assignment for your touchpad.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-07 18:41:16 -0500

Seen: 1,308 times

Last updated: Jul 15 '15