Ask Your Question
0

Unable to open VMs in virtualbox in fedora 22

asked 2015-06-07 01:33:22 -0500

chaitu9 gravatar image

Hi,

I am unable to open VMs in virtualbox with fedora22.

**>> VBoxManage --version

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (4.0.4-303.fc22.x8enter code here6_64) or it failed to load. Please recompile the kernel module and install it by sudo /etc/init.d/vboxdrv setup You will not be able to start VMs until this problem is fixed. 4.3.28r100309

sudo /etc/init.d/vboxdrv setup

Stopping VirtualBox kernel modules [ OK ]

Recompiling VirtualBox kernel modules [FAILED]

(Look at /var/log/vbox-install.log to find out what went wrong)

--->cat /var/log/vbox-install.log

Makefile:183: * Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again. Stop.*

Can anyone help me how to resolve this.

Thanks in advance. :)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-07 03:22:59 -0500

Glenn gravatar image

Has there been a kernel update for you? This is typical behavior if there has been a kernel update and you've rebooted. If so, and you've booted into that new kernel, you need to install kernel-devel for that new kernel and then run /etc/init.d/vboxdrv setup.

edit flag offensive delete link more

Comments

Thanks a ton!!! It worked! I installed kernel-devel with sudo dnf install "kernel-devel-uname-r == $(uname -r)"

chaitu9 gravatar imagechaitu9 ( 2015-06-07 04:13:24 -0500 )edit

Hi! I have the same problem just that i have the kernel "4.0.7-300.fc22.x86_64" and have installed the kernel-devel too. but still fail to start "VirtualBox kernel modules".

[root@Chuy-X45C ~]# /etc/init.d/vboxdrv setup Stopping VirtualBox kernel modules-[ OK ] Uninstalling old VirtualBox DKMS kernel modules-[ OK ] Trying to register the VirtualBox kernel modules using DKMS-[ OK ] Starting VirtualBox kernel modules-[FAILED]

Osuna.J gravatar imageOsuna.J ( 2015-07-15 17:13:53 -0500 )edit

Try to Disable "Secure Boot Option" in Bios Setting and then try following command

sudo /etc/init.d/vboxdrv setup

Raghu2015 gravatar imageRaghu2015 ( 2015-08-10 00:02:37 -0500 )edit
0

answered 2015-08-09 21:47:59 -0500

nat gravatar image

Try installing DKMS

with sudo dnf install DKMS.noarch

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2015-06-07 01:33:22 -0500

Seen: 9,603 times

Last updated: Jun 07 '15