Ask Your Question
1

unable to select right screen-resolution in Fedora 22

asked 2015-06-06 14:00:14 -0500

Omernow gravatar image

updated 2015-06-07 18:20:00 -0500

mether gravatar image

I upgrade from Fedora 20 to Fedora 22. But now i cannot select my native resolution anymore.

What can i do?

Dell Laptop D430

Update: i downgraded to Fedora 21 and now i'am able to use my native resolution again:-).

Yours Kindly Omer

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-07 17:04:28 -0500

wafra gravatar image

Open the All Settings ( click on power icon @ top right of screen ) click on crossed screw driver/wrench icon click on Displays double click Display 1 expand the resolution drop down menu choose resolution

edit flag offensive delete link more

Comments

It sounds like the OP may have already tried this...my understanding is that there is some sort of driver issue where the correct resolution is not showing up in the drop-down menu.

mattingly890 gravatar imagemattingly890 ( 2015-06-07 18:43:36 -0500 )edit
0

answered 2015-06-10 15:09:16 -0500

Omernow gravatar image

Indeed the problem is, that my screen has a native resolution of 1280 x 800. But the highest resolution i can select is 1024 x 768.

I had to try Fedora 22 when it was in beta.

The GPU is a INTEL Mobile 945GM, the current module is i915. So in F22 it is not working well.

Is it possible - after the release - to notify that this regression exist?

Yours kindly

edit flag offensive delete link more
0

answered 2016-04-07 21:04:16 -0500

Josh gravatar image

updated 2016-04-08 16:37:20 -0500

I'm having a similar problem with fedora 21 when I boot in uefi mode. Bios mode boots in full resolution but boots at reduced resolution.

Edit: turns out my the newer intel graphics hardware required the "i915.preliminary_hw_support=1" flag which solved my problem.

edit flag offensive delete link more

Comments

I too have the same problem after changing my graphics card and upgrading to newer kernel. Can you tell me how you have got "i915.preliminaryhwsupport=1" flag. I can make a trial with it.

lutu gravatar imagelutu ( 2017-08-16 00:07:26 -0500 )edit
0

answered 2015-06-10 19:59:50 -0500

bthomas gravatar image

updated 2015-06-10 20:41:40 -0500

Run xrandr from the terminal. Does your screen resolution show up? If it does, then it's probably a problem with Gnome. If not, then it's probably more to do with Xorg/Drivers. If it does show up, then you can manually set the resolution with xrandr --output eDP1 --mode "1366x768" assuming your resolution is is 1366x768 and your screen name (shown by xrandr is eDP1).

Also, according to man xrandr (see for details), you might be able to force a screen size change with

xrandr --newmode "1024x768" 63.50  1024 1072 1176 1328  768  771 775 798 -hsync +vsync
xrandr --addmode VGA 1024x768
xrandr --output VGA --mode 1024x768
edit flag offensive delete link more

Comments

Thank you, this fixed my problem. The screen size was really small and it was not possible to run the Display GUI program.

However once I ran xrandr --output VGA-1 --mode "1920x1200" it seemed to knock some sense into it and it suddenly worked. After that I could auto resize the resolution just by resizing the window from the host. And it was possible to run Display again too.

qarj gravatar imageqarj ( 2016-06-15 14:49:10 -0500 )edit

Question Tools

Stats

Asked: 2015-06-06 14:00:14 -0500

Seen: 15,974 times

Last updated: Apr 08 '16