Ask Your Question
1

Fedora 22: full-screen tearing/flickering under KDE

asked 2015-06-03 20:09:27 -0500

Matthew Cline gravatar image

After upgrading to Fedora 22, things are fine for around ten to thirty after I login to a KDE session, but after then I'll get full-screen flickers/tearing, which sometimes happens when switching focus between windows, but always happens (a whole bunch) when trying to logout via the taskbar's "start menu". It seems to be related to usage of Workrave.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
4

answered 2015-06-03 20:17:39 -0500

Matthew Cline gravatar image

updated 2015-06-04 05:34:12 -0500

I've found two ways to solve the problem, both via System Settings > Hardware > Display and Monitor > Compositor (or run the command kcmshell5 kwincompositing). Either change tearing prevention to "Full screen repaints", or change the rendering backend from OpenGL to XRender. The first option gives the warning that it can cause performance problems, while the second option disables certain desktop transparency effects.

EDIT: A third method: grep $HOME/.xsession-errors for Triple buffering detection. If this results in a line saying that triple buffering is NOT Available, you can solve the problem by giving the environmental variable KWIN_TRIPLE_BUFFER to kwin. In /etc/profile.d place a file named kwin.sh (or anything ending in .sh) containing the line:

export KWIN_TRIPLE_BUFFER=1

You'll then need to logout and back in again for the solution to take effect.

edit flag offensive delete link more

Comments

Excellent! Now, all you need to do is mark your answer as correct and collect a badge for it.

sideburns gravatar imagesideburns ( 2015-06-04 00:35:55 -0500 )edit

The fix included in the EDIT worked for me. Thanks so much!

xmetax gravatar imagexmetax ( 2015-09-03 11:43:52 -0500 )edit

Yesss!! Sadly, I can't upvote, so this question and answer will have to fester in the lower strata of the barrel.

Donkey Man of the Apocalypse gravatar imageDonkey Man of the Apocalypse ( 2015-10-17 11:19:49 -0500 )edit
0

answered 2016-05-11 08:56:10 -0500

ja gravatar image

First option works for me, thank you so much!

edit flag offensive delete link more
0

answered 2018-05-28 05:39:25 -0500

I have the same problem with intel driver on Debians. It's PSR bug: see https://wiki.archlinux.org/index.php/...graphics#Screenflickering So you must disable it. In Debian I add in to /etc/default/grub: GRUBCMDLINELINUX=" i915.enable_psr=0" And run sudo update-grub, to regenerate /boot/grub/grub.cfg.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-03 20:09:27 -0500

Seen: 10,081 times

Last updated: May 28 '18