Ask Your Question
0

No more broadband after Fedora 22 fresh install

asked 2015-06-02 07:05:45 -0500

jncolin gravatar image

Hi

I have a Lenovo x240 laptop; I performed a fresh install of Fedora 22 and must say I'm rather happy with it. The only trouble so far is that I have lost the broadband connection. The laptop has a SIM slot, which is recognized under Fedora 21, Ubuntu, Mint... but although the device seems to be recognized, it is not possible to add a broadband connection in the Network settings (there is no such item in the list)

Would anyone know what's going on?

Best regards

Jean-Noël

root@enigma ~> dmesg | grep -i cdc
[    2.695069] cdc_wdm 1-4:1.5: cdc-wdm0: USB WDM device
[    2.695981] cdc_wdm 1-4:1.8: cdc-wdm1: USB WDM device
[    2.696002] usbcore: registered new interface driver cdc_wdm
[    2.699794] usbcore: registered new interface driver cdc_ncm
[    2.719996] cdc_mbim 1-4:1.6: cdc-wdm2: USB WDM device
[    2.720192] cdc_mbim 1-4:1.6 wwan0: register 'cdc_mbim' at usb-0000:00:14.0-4, CDC MBIM, ba:a7:52:c4:0f:7f
[    2.720209] usbcore: registered new interface driver cdc_mbim
[    2.721148] cdc_mbim 1-4:1.6 wwp0s20u4i6: renamed from wwan0
[    3.682225] cdc_acm 1-4:1.1: ttyACM0: USB ACM device
[    3.685650] cdc_acm 1-4:1.3: ttyACM1: USB ACM device
[    3.692048] cdc_acm 1-4:1.9: ttyACM2: USB ACM device
[    3.692449] usbcore: registered new interface driver cdc_acm
[    3.692451] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
root@enigma ~>
edit retag flag offensive close merge delete

Comments

does it need a specific kernel module ? did you check if it's installed with lsmod | grep cdc or modprobe ?

baoboa gravatar imagebaoboa ( 2015-06-03 08:06:23 -0500 )edit

9 Answers

Sort by » oldest newest most voted
3

answered 2015-06-05 08:04:16 -0500

Period 22 gravatar image

updated 2015-06-09 05:07:29 -0500

Similar situation with a Thinkpad with Sierra Wireless module. It worked fine in Fedora 21, but it is not available under Gnome in Fedora 22. lsusb lists it, but Mobile Broadband is not in Network Manager.

Solution: It seems ModemManager is not enabled by default in F22, at least not with some installations.

This post says: ModemManager is required for gnome network manager to detect any mobile broadband devices. This needs to be enabled with sudo systemctl start ModemManager and sudo systemctl enable ModemManager. As soon as they are started the Mobile Broadband option will be available from the Network Manager Applet.

This worked for me, and, yes, the change is persistent.

edit flag offensive delete link more

Comments

-FEDORA 22 KDE Scientific (64bit) edition after install more some KDE network packages ====now working with Wifi and 3G ====

afeher.gyor gravatar imageafeher.gyor ( 2015-06-12 10:33:29 -0500 )edit

+1 Thank you! Running the 2 modem manager commands in this answer worked for me on FC22. Don't you just love it when the solution is so simple and you don't have to go and recompile your kernel?

grenade gravatar imagegrenade ( 2015-10-25 03:24:49 -0500 )edit

Works also on my X230. Thanks!

vsht gravatar imagevsht ( 2015-12-02 15:00:47 -0500 )edit
0

answered 2015-06-13 12:27:01 -0500

Sorry man, maybe i will not help you, but now i'm with fedora 21 and i want to use the broadband with my SIM. How did you do that? (i'm using gnome)

could you help me please?

bye and good luck

edit flag offensive delete link more
0

answered 2015-06-03 11:23:27 -0500

This might be silly, but did you check if it is listed in the upper-right menu (where the power symbol is)?

The other place I think to check is the Network settings in Settings

I've never had broadband in my machine, but that is where my cell phone has shown up.

edit flag offensive delete link more
0

answered 2015-06-03 10:34:48 -0500

Exactly the same for me on a lenovo T540p. Internal sim card not picked. My usb 3G and LTE dongles are picked up but I'm unable to create a mobile broadband connection

edit flag offensive delete link more
0

answered 2015-06-14 19:01:09 -0500

Phuti gravatar image

Search "Network", click Network and if usb modem is plugged in it will appear in the list of available networks. if this doesn't work do sudo systemctl start ModemManager and sudo systemctl enable ModemManager And restart your desktop and plug in your modem, go to the network and see if it appears in the list of available networks.

edit flag offensive delete link more
0

answered 2015-07-24 06:58:31 -0500

Just encountered this issue in a new install of Fedora 22 on a Lenovo T450s. Had to add the ModemManager and then use systemctl to enable and start it. So, thanks for the tips.

Harish

edit flag offensive delete link more
0

answered 2015-08-15 13:06:05 -0500

Yog gravatar image

Had a same issue with Huawei E117, steps mentioned in one of the responses did the trick.

sudo systemctl start ModemManager and sudo systemctl enable ModemManager

edit flag offensive delete link more
0

answered 2015-06-12 10:30:15 -0500

I have problem with HUAVEI K3767 USB 3G modem too both system install: - FEDORA 22 32 bit - FEDORA 22 KDE scientific 64 bit

edit flag offensive delete link more
0

answered 2015-06-12 03:22:03 -0500

I try fedora 22 (with Huawei K3765 USB 3G stick) - 32 bit DVD -64 bit scientific DVD the same problem.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-06-02 07:05:45 -0500

Seen: 5,839 times

Last updated: Jun 14 '15