Ask Your Question
0

F22 upgrade, No sound through HDMI

asked 2015-06-01 09:43:15 -0500

Fred2010 gravatar image

Just upgraded my F20 desktop this weekend, first to F21 and then this morning to F22.

The only problem I noticed is the HDMI sound no longer works. It stopped working after the F20 --> F21 upgrade.

I experienced the same problem with F20 and I believe I fixed it using the suggestion HERE (adding radeon.audio=1 to the grub config).

I tried the solution I used before with F20, but it no longer works (with F22).

edit retag flag offensive close merge delete

Comments

I don't know if this will help, but here is the output of the aplay -l command,

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Fred2010 gravatar imageFred2010 ( 2015-06-01 09:54:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-16 05:28:47 -0500

xavierb gravatar image

updated 2015-06-16 17:06:19 -0500

Hi,

This is a bug in kernel 4.0. kernel 4.1 has/will have the fix. I have confirmed it's fixed with 4.0rc7 from the rawhide-kernel-nodebug repository. See https://fedoraproject.org/wiki/Rawhid... for details on the repo. The dnf command to install the repo is : dnf config-manager --add-repo=http://alt.fedoraproject.org/pub/alt/rawhide-kernel-nodebug/fedora-rawhide-kernel-nodebug.repo

Hope this helps,

Xavier

edit flag offensive delete link more

Comments

Thank you.I thought it was something like a kernel bug. However, don't think I want to try a rawhide kernel. I will wait until the fix comes to the standard kernel.

Fred2010 gravatar imageFred2010 ( 2015-06-17 07:29:21 -0500 )edit

With the kernel updated to 4.0.5-300, I can now report that the HDMI sound issue is now resolved on my computer. I applied the kernel update yesterday (June 21) using the standard command for updating Fedora, namely:

sudo dnf update

Fred2010 gravatar imageFred2010 ( 2015-06-22 09:38:21 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-01 09:43:15 -0500

Seen: 2,313 times

Last updated: Jun 16 '15