Ask Your Question
1

Upgrade Fedora21 to 22 with fedup fails on multiboot system

asked 2015-05-31 05:16:12 -0500

jprause gravatar image

updated 2015-05-31 14:19:50 -0500

NickTux gravatar image

When upgrading Fedora 21 to 22 I followed the procedure described in How to Upgrade from Fedora 21 to Fedora 22.

Everything went fine but the step 4 - Reboot and upgrade: After rebooting there was no “System Upgrade (fedup)” option in the boot menu so I was not able to finish the upgrade.

Note: my Fedora is one of three systems on my multiboot desktop. The others are Ubuntu and Mint. Any hint how to finish the upgrade? Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-05-31 10:31:26 -0500

NickTux gravatar image

updated 2015-05-31 14:16:52 -0500

Because of the multiboot system you said you have,

are you sure that Fedora's Grub is installed in Disk's MBR ? If you have another Grub (Ubuntu or Mint) installed then of course you won't see any option there about "System Upgrade" or similar. Please make sure you have Fedora Grub installed or if in doubt login to Fedora and do

grub2-mkconfig -o /boot/grub2/grub.cfg 
grub2-install --recheck /dev/sda

I assume here you have only ONE disk drive and for that I'm giving you the sda . If that's not the case, replace sda with the coresponding Disk that Fedora is installed and also make sure that this disk is First in BIOS Boot Sequence.

Alternatively, and if you don't want to change the GRUB installation, you should login to the distribution which its GRUB is installed as the mainly GRUB and update it. For Ubuntu and ubuntu-based distributions the command to update grub is

sudo update-grub

Then reboot and possibly you will see the new Fedora entry there.

edit flag offensive delete link more

Comments

Thank you, Nick. My issue is SOLVED. Let me describe how: I rebooted my desktop and chose "Fedora 21..." from the grub menu. Fedora started automatically its upgrading showing the process on tty screen. When it finished after some time I rebooted and logged in into Ubuntu, updated grub with sudo update-grub and after reboot I could see Fedora 22 on grub menu. Logged into Fedora22 successfully, works great.

jprause gravatar imagejprause ( 2015-05-31 13:53:07 -0500 )edit

@jprause if the answer above helped you to resolve the problem consider to upvote it or/and mark the answer as the correct one. I would suggest to install the Grub bootloader as the mainly GRUB on your system of the distribution you are using most.

NickTux gravatar imageNickTux ( 2015-05-31 14:02:02 -0500 )edit

Also, I have updated the answer to correspond in what you did (in case someone don't want to replace the GRUB).

NickTux gravatar imageNickTux ( 2015-05-31 14:07:13 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-05-31 05:16:12 -0500

Seen: 552 times

Last updated: May 31 '15