Ask Your Question
4

How do I reduce the size of everything in my display

asked 2015-05-30 03:36:08 -0500

grenade gravatar image

My system has a display resolution of 2560 x 1440. On Windows, if I want bigger fonts, I just select a lower display resolution. On Fedora 22, everything is already big with the highest resolution. I prefer to use the screen real estate differently. I want everything (fonts, window borders, icons in the task bars, etc) to be much smaller. How do I make this work?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2015-05-30 06:03:58 -0500

cobra gravatar image

Which desktop environment are you using?

If you're using Mate, then look under System->Preferences->Look and Feel->Appearance (or it might be System->Preferences->Appearance depending on which packages you have). That tool gives you control over pretty much everything on the desktop.

If you'e using Gnome, then perhaps others could chip in as I don't use that DE.

edit flag offensive delete link more

Comments

I'm using Gnome (a default install of Fedora 22 from the LiveCD).

grenade gravatar imagegrenade ( 2015-05-30 10:50:41 -0500 )edit
1

answered 2015-05-30 12:19:44 -0500

grenade gravatar image

I found some kind of solution, it's not perfect but, it's closer to what I am used to and need (run these in the terminal):

# Reduce font sizes (adjust "0.6" to some value that suits you. eg: 2.0 = twice the size, 0.5 = half the size)
gsettings set org.gnome.desktop.interface text-scaling-factor 0.6

# Reduce Title Bar heights (takes effect after session restart/logout,login)
cat > ~/.config/gtk-3.0/gtk.css <<EOF
.header-bar.default-decoration {
  padding-top: 0;
  padding-bottom: 0;
}
GtkButton {
  padding-top: 0;
  padding-bottom: 0;
  margin-top: 0;
  margin-bottom: 0;
}
>EOF

Additionally, I tweaked my browser with the instructions here: https://wiki.archlinux.org/index.php/... . I kept some other notes here: https://gist.github.com/grenade/6363978

edit flag offensive delete link more
1

answered 2016-10-24 11:05:20 -0500

wavis gravatar image

Try setting org.gnome.desktop.interface scaling-factor using gsettings or gnome-tweak-tool via its "window scaling" field.

image description

via askubuntu.com

Honestly this answer is not satisfactory to me. The scaling factor seems restricted to integers, and 1 is tiny, and 2 is huge. This really needs to be a float.

edit flag offensive delete link more

Comments

There is an experimental setting that allows not integer scaling, however it must be positive (larger than 1, 100%)

alfC gravatar imagealfC ( 2019-03-04 22:00:59 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-05-30 03:36:08 -0500

Seen: 8,343 times

Last updated: Oct 24 '16