Ask Your Question

KDE Freezes shortly after logging in (F22)

asked 2015-05-28 22:05:50 -0500

Fman1257 gravatar image

updated 2015-06-02 13:33:05 -0500

Hello all,

I recently installed Fedora 22 Workstation on my desktop, and I installed KDE Plasma 5 from the official repository. Shortly after the DE loads, however, the system becomes unresponsive. The time it takes for this to happen varies. The mouse and keyboard shortcuts do not seem to work, and it's as if my computer is completely frozen. I can use the default GNOME DE without any issues. I had previously installed the KDE Spin of F22 and ran into the same issue. I'm not sure if I should file this as a bug or not, and I am not sure if there are any log files that would tell me what the issue is. I have used Linux in the past, but I am by no means an expert user. Any help would be greatly appreciated.

Current running kernel (UPDATED): 4.0.4-303

EDIT: I am including a list of things I have tried to do of what I have done to fix the issue.

  1. I upgraded the system using dnf upgrade.
  2. I attempted to install the nvidia drivers from the RPM Fusion repositories. This caused issues with other parts of my system (which I will explain further down) and as a result I uninstalled them.
  3. I then attempted to remove and reinstall the KDE package group, however due to a bug with dnf I cannot do so.
  4. I tried dnf distro-sync --enablerepo=updates-testing. Since that did not fix the issue, I reran dnf distro-sync to downgrade my system.

According to sergiomb below, it seems to be an issue with my graphics drivers, and I also believe that the lack of these drivers is causing KDE to freeze after a period of time. However, installing the proprietary drivers caused an issue with starting GDM after reboot. Basically, after I install the nVidia drivers, I reboot the system and boot into the latest kernel. I get to the boot screen of fedora (with the logo), and after a short amount of time, I get the "Oops, something went wrong message" from GDM. That screen will pop up again if I press escape as well. This has happened every time I attempted to install the nVidia drivers.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-06-04 13:52:58 -0500

Fman1257 gravatar image

updated 2015-06-04 13:56:29 -0500

I have managed to solve my problem. The source of my issue with KDE was that I was using the default nouveau drivers, which crashed when running KDE. Installing the nVidia drivers conflicted with these drivers, and caused GDM to fail after a reboot. I followed the instructions here and it allowed me to run KDE without any crashes. This method does involve installing the binaries from the nVidia website. I will try to install the ones from the RPMFusion repositories at some point, but for now this solves my issue.

edit flag offensive delete link more



Accept your own answer as correct! Thanks for reporting back.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-06-04 16:27:59 -0500 )edit

I need 20 points to mark it as correct :(

Fman1257 gravatar imageFman1257 ( 2015-06-04 17:45:51 -0500 )edit

@Fman1257 Nice work.... you got 20 points now.... :-)

somethingSomething gravatar imagesomethingSomething ( 2015-06-05 15:14:35 -0500 )edit

Install Nvidia from RPMFusion should be easy and you will have less work on kernel updates take a look at

sergiomb gravatar imagesergiomb ( 2015-06-06 10:54:08 -0500 )edit

Can I install the drivers from the RPM Fusion repositories if I have the official binaries from nVidia currently installed? Will that create any conflicts in the system?

Fman1257 gravatar imageFman1257 ( 2015-06-07 23:33:35 -0500 )edit

answered 2015-05-30 15:48:07 -0500

sergiomb gravatar image

hi, you got many updates of kde , please try update the system and see if fix something , anyway what video card do you have ? and drives that you use ?

edit flag offensive delete link more


Hi. I am up to date with my updates. My computer is about 4-5 years old. The video card is EVGA GeForce GTS 450 1GB. I have a single regular SATA hard drive that's pretty new. I hope that helps! [Edit: Oops, I thought this was my question, but it's just a similar one that I'm following! Sorry. Anyway, hopefully this is helpful to someone.]

reid gravatar imagereid ( 2015-05-30 16:57:49 -0500 )edit

Hello. I just attempted to update using dnf and there was no packages to be updated. My video card is an nVidia GTX 660 (by EVGA). By "drives", do you mean drivers? If so, then I am using the default drivers that came with the Fedora installation. I attempted to install the nVidia drivers from the RPM Fusion repositories but that caused GDM to crash on startup, so I uninstalled them. I assumed that you meant drivers because I do not see how my single hard drive would cause an issue in this case.

Fman1257 gravatar imageFman1257 ( 2015-05-30 17:41:32 -0500 )edit

I just updated using dnf upgrade instead of dnf update, and it found some of the KDE packages to update. However, because there was a conflict it would not let me install those updates. My next plan is to uninstall KDE and reinstall, however there is currently a bug in dnf that prevents the removal of package groups ( ).

Fman1257 gravatar imageFman1257 ( 2015-05-30 18:16:29 -0500 )edit

@Fman1257, drives in your case Nvidia , could be nouveau xorg-x11-drv-nouveau or binaries of nvidia ? . @Fman1257 1srt you should do : dnf distro-sync --enablerepo=updates-testing , after if you still can't update try dnf update --best to see if you find the problem , also you still could use yum, now with yum-deprecated or do on alias alias yum='yum-deprecated'

sergiomb gravatar imagesergiomb ( 2015-05-30 19:49:53 -0500 )edit

How do I check which video drivers I currently have enabled? Also will enabling the "updates-testing" repo make my system less stable? EDIT: I just attempted your first suggestion, and it did not fix my issue.

Fman1257 gravatar imageFman1257 ( 2015-05-30 23:05:02 -0500 )edit

Question Tools



Asked: 2015-05-28 22:05:50 -0500

Seen: 5,234 times

Last updated: Jun 04 '15