Ask Your Question

How to write fedora iso file in usb?

asked 2015-05-28 11:52:50 -0500

Shazia gravatar image

updated 2015-06-07 18:23:23 -0500

mether gravatar image

I am very new in linux as right now using debian stable but would like to come to fedora 22 and I downloaded the file as well. but here in debian no unetbootin works and I tried lots of ways to write disk image of fedore in usb but it end up in error somehow. please someone explain me how to properly write iso file in usb without any error. By the way my usb is perfect no problem in it i checked.

edit retag flag offensive close merge delete


WHat desktop do you use in Debian? If it is GNOME, you can use "Disks" app.

Or you may try fedora liveusb-creator. You may have to install it from the source. (I doubt whether you will get this app as a .deb package)

deadrat gravatar imagedeadrat ( 2015-05-28 18:49:25 -0500 )edit

I have debian 8stable gnome desktop and i tried both methods above but everytime it says complete but in my 8gb usb its becaome 29gb and 4 sections in usb when see in gparted. please advice if i need to unmount ubs before doing the methods above or its ok to do directly.

Shazia gravatar imageShazia ( 2015-05-29 00:46:13 -0500 )edit

@Shazia , just a personal recommendation. Rather than trying it so many times, consider creating it using a friend's PC or try to create a bootable DVD. If that is not possible, maybe some one who is familiar with Debian might know what is up.. Consider asking the question in a Debian support forum.

deadrat gravatar imagedeadrat ( 2015-05-29 03:25:55 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2015-05-28 12:03:29 -0500

aeperezt gravatar image

updated 2015-05-28 15:54:33 -0500

Will recommend to read this page:

Since you are in Debian you could use dd to do the job something like this using that link page sample:

sudo dd if=/Users/me/Downloads/Fedora-Live-Desktop-x86_64-20-1.iso of=/dev/sdX bs=8M

edit flag offensive delete link more


I think you got your command line a tad confused. The command sudo doesn't have an option -c, nor does the following command line get quoted. I think you're probably thinking of su, which does understand -c and needs the command line to be quoted if there are any spaces in it.

sideburns gravatar imagesideburns ( 2015-05-28 15:13:29 -0500 )edit

You are correct, sorry. Fixed

aeperezt gravatar imageaeperezt ( 2015-05-28 15:55:08 -0500 )edit

answered 2015-05-28 17:25:06 -0500

sergiomb gravatar image

First you need format your usb in vfat file system, choose carefully your /dev or you will format others things ( in this example I use /dev/sdb1 )

mkfs.vfat /dev/sdb1

just format the usb if it isn't in vfat else we don't need this mkfs.vfat.

/usr/bin/livecd-iso-to-disk boot.iso /dev/sdb1

(same device used in format)

You can check if everything is fine without reboot , using:

qemu-system-i386  -hda /dev/sdb -boot c

Check if pen usb boots ! if not get odin1440.img ( )

qemu-system-i386  -hda /dev/sdb -fda odin1440.img -boot a

and do :

fdisk /mbr 1
edit flag offensive delete link more

answered 2015-05-28 21:37:25 -0500

Santosh Ghimire gravatar image

updated 2015-05-28 21:41:37 -0500

There you go friend. The official way..

Easiest Way of doing this from Fedora itself is with GNOME Disks

On a system with GNOME, or with the gnome-disk-utility package installed, open Disks using the system menu.
Click your USB device in the left column.
Click the menu icon in the upper right corner of the window, and choose the Restore Disk Image option.
Navigate to your image file and click Start Restoring. After a few minutes, it will report the process is complete and your installation media will be ready to use.

Welcome to Fedora World ! :)

edit flag offensive delete link more

Question Tools


Asked: 2015-05-28 11:52:50 -0500

Seen: 428 times

Last updated: May 28 '15