Ask Your Question
0

Screen flashing black on some applications with 4K display

asked 2015-05-28 05:52:47 -0500

Nick.m gravatar image

Hi, i recently bought my new laptop DELL Inspiron 15 7548 and installed fedora 22. I'm facing problems with many linux distribution that doesn't work with hidpi scaling (my display is 4K with 3840x2160 resolution), but fedora solve it very well.

It's still an issue the intermittent black screen while surfing in internet with Firefox or Google Chrome. I also found the same bug in Ubuntu : https://bugs.launchpad.net/ubuntu/+so... , and in Gnome desktop: https://bugs.freedesktop.org/show_bug... . So

display blinks right after Chrome [or Firefox] opened, back to normal when you close the browser

#  lspci -k | grep -A3 VGA

outputs

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
    DeviceName:  Onboard IGD
    Subsystem: Dell Device 066f
    Kernel driver in use: i915
--
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] (rev ff)
    Kernel driver in use: radeon
    Kernel modules: radeon

I tried these fixes

  • Installing the Proprietary AMD Catalyst 14.12 FAILED [source: http://bit.ly/1ez2dy9 ]
  • Passing the option i915.enable_ips=0 to kernel upon boot, i.e. append this line in GRUB_CMDLINE_LINUX on /etc/default/grub FAILED

I hope your answers will help 4K's customers. Thanks for your replies

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-24 05:24:07 -0500

Hi Nick.m, I have the same laptop. First, I tried the first option (install catalyst) but didn't solve my problem.

I solved the problem using the second, but It was no simple. First I tried to change the boot options, adding the argument i915.enable_ips=0 to GRUB_CMDLINE_LINUX on in /etc/default/grub but it does not work after run grub2-mkconfig -o /boot/grub2/grub.cfg.

It was because I have UEFI boot. Grubx64.efi uses EFI/fedora/grub.cfg in your UEFI file system. Then, in order to update that file you should run sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg.

You can test it running sudo cat /boot/efi/EFI/fedora/grub.cfg or in grub menu you press "e" and should view the i915.enable_ips=0 argument in linuxefi invocation.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-28 05:52:47 -0500

Seen: 1,276 times

Last updated: May 28 '15