Ask Your Question
1

Slow laptop after update Fedora 21 to Fedora 22

asked 2015-05-27 10:54:27 -0500

semen gravatar image

updated 2015-05-28 08:38:06 -0500

mether gravatar image

After upgrade Fedora 21 to fedora 22 with fedup i have general slowdown and great response time. Steps to Reproduce: 1. sudo fedup --network 22 (into Fedora 21) 2. Reboot and update Fedora 21 to Fedora 22. 3. Start Fedora 22.

I have big delay when i start an software (playonlinux, firefox and other). Sometimes (after start software) i see static screen and i can do nothing. Folders in my laptop open slowly too (Nautilius).

I openned the bug in the bugzilla: https://bugzilla.redhat.com/show_bug....

edit retag flag offensive close merge delete

Comments

Had the same problem here :(

paladini gravatar imagepaladini ( 2015-06-04 06:43:58 -0500 )edit

6 Answers

Sort by ยป oldest newest most voted
1

answered 2015-05-27 12:19:38 -0500

shatadru gravatar image

You can start basic troubleshooting by checking sar,top,free etc. Then you can check strace :

 strace -f <command>
 strace -cf <command>

Best Regards Shatadru B.

edit flag offensive delete link more

Comments

Load CPU is ok. Free mem is ok too.

semen gravatar imagesemen ( 2015-05-27 15:47:41 -0500 )edit
0

answered 2015-05-28 04:12:45 -0500

This bug affects my system too. It's so frustrating that it forced me to create an account here.

edit flag offensive delete link more

Comments

Installed xorg-x11-drv-intel and this move has improved the performance considerably.

vergeon gravatar imagevergeon ( 2015-05-29 01:32:17 -0500 )edit
0

answered 2015-05-28 20:17:20 -0500

Hi, I have the same problem. It is somehow related to X. When I start a Wayland session, I do not have any slowing but the interface is bad.

edit flag offensive delete link more
0

answered 2015-06-04 07:10:54 -0500

paladini gravatar image

Based on @sunckell answer, I wrote the following sentences that can (probably) fix your issues with Fedora 22 (on Intel computers). You just need to re-install the following packages:

sudo dnf remove xorg-x11-drv-intel intel-gpu-tools libva-intel-driver

sudo dnf install xorg-x11-drv-intel intel-gpu-tools libva-intel-driver

Hope it help you and all the other guys with the same problem.

edit flag offensive delete link more

Comments

This fixed my problem.

curiosu gravatar imagecuriosu ( 2016-11-16 22:10:09 -0500 )edit
0

answered 2015-05-27 13:01:01 -0500

Santosh Ghimire gravatar image

Why don't you run

yum autoremove

to clean some packages..

edit flag offensive delete link more

Comments

I have not got an packages for autoremove.

semen gravatar imagesemen ( 2015-05-27 15:48:42 -0500 )edit
0

answered 2015-05-29 06:47:42 -0500

I had the same problem. But for Fedora 21 (prior to the upgrade) I had Intel Linux driver repositiory configured. I uninstall all the intel rpm packages (libva-intel-driver, xorg-x11-drv-intel, intel-gpu-tools) then removed the Intel repository and installed the rpm packages again. ( rebooted, logged back in with gnome X11, and everything is operating correctly now. No slow startup times.

edit flag offensive delete link more

Comments

Reinstalling the intel packages worked for me, too. I had the problem only on the Linux kernel 4.04, 3.19 worked fine before.

fab671 gravatar imagefab671 ( 2015-05-30 10:49:56 -0500 )edit

Question Tools

Stats

Asked: 2015-05-27 10:54:27 -0500

Seen: 3,169 times

Last updated: May 27 '15