Ask Your Question
0

Could not connect to bumblebee daemon on Fedora 22

asked 2015-05-23 08:13:42 -0500

SaeedMasoumi gravatar image

I've installed bumblebee on my Fedora 22 from fedora wiki page . My notebook runs on UEFI and has two graphic cards (nVidia GTX860m and Intel 4400).

#lspci | grep VGA
VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
#lspci | grep NVIDIA
3D controller: NVIDIA Corporation GM107M [GeForce GTX 860M] (rev a2)

After installation of bumblebee i rebooted my system then i tried to test bumblebee with this command :

#optirun glxgears
[  812.297902] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[  812.297935] [ERROR]Could not connect to bumblebee daemon - is it running?

then i tested this

# bumblebee-nvidia
--force compile selected via /etc/sysconfig/nvidia/compile-nvidia-driver
This script must be run as root. Exiting...
[saeed@localhost selinux]$ sudo bumblebee-nvidia
--force compile selected via /etc/sysconfig/nvidia/compile-nvidia-driver
Building NVIDIA video drivers: Creating directory NVIDIA-Linux-x86_64-346.47
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 346.47...........................................................................................................................................................................................................................................................
patching file kernel/nv-pat.c
                   [FAILED]

And:

#bumblebeed 
modprobe: FATAL: Module bbswitch not found.
[  924.996622] [ERROR]Module bbswitch could not be loaded (timeout?)
[  924.996656] [WARN]No switching method available. The dedicated card will always be on.
[  924.997915] [ERROR]Module 'nvidia' is not found.

Also i disabled SElinux before installation. Any ideas?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-07-22 21:26:09 -0500

Omastro gravatar image

Hello,

You are not alone! I have spent several hours (too many) trying to figure out this problem. They run the nvidia-installer in quiet mode so since you run on UEFI (as I do) you might like me cannot disable secure boot.

Do you still have the problem? I might be able to help you get passed the [FAILED] however I am stuck now and having errors launching the xserver, maybe you can tell me how you did if you succeeded :D

edit flag offensive delete link more
1

answered 2015-05-23 18:10:12 -0500

geforce gravatar image

updated 2015-05-23 18:10:52 -0500

The patch their using is the same as this so should apply clean

http://cvs.rpmfusion.org/viewvc/rpms/...

Have you tried running the script as proper root (none of that sudo rubbish :-) ) to see if that helps.

edit flag offensive delete link more

Comments

Yes , i tested those commands as root and non root and same results appear

SaeedMasoumi gravatar imageSaeedMasoumi ( 2015-05-24 00:04:05 -0500 )edit
0

answered 2015-08-16 22:45:19 -0500

Helio gravatar image

I have the same problem too

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-23 08:07:00 -0500

Seen: 2,026 times

Last updated: May 23 '15