Ask Your Question
0

VNC connection from a MacBook

asked 2015-05-20 02:00:00 -0500

I have Fedora 21 installed on a desktop and am trying to access the files on it from a MacBook (running OSX 10.6.8). I'm able to access the MacBook's files on the desktop using Nautilus, and I can ssh into the desktop from the laptop, but I can't establish a connection using the Mac Finder, vnc, or ftp. I think it's a problem on the Linux side, but I don't really know what I'm doing ... I've enabled screen sharing, file sharing, and remote log-in through the GUI (Gnome environment), and I can see the 'remote desktop' listed under 'Shared' on the Mac Finder, but when I click to connect, it just says "Contacting" interminably. Is there something else I need to set up on the Linux end?

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. Have you made sure that the firewall allows incoming connections on the ftp port? I'm not sure, but I don't think it's open by default. Alas, I don't use Gnome, so I'm not sure what GUI you'll have to use.

sideburns gravatar imagesideburns ( 2015-05-20 03:13:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-20 06:16:04 -0500

pnadk gravatar image

If you only need to access the files from the other computer, then you don't need to share your desktop. Since SSH is already working, you can use that. Programs like FileZilla can access the remote files over SSH.

On the other hand, if you need to remotely access the desktop then you must allow that in the firewall and use a VNC client on the Mac side.

edit flag offensive delete link more

Comments

I do need to access the desktop (I want to view and manage photo files without copying them over to the laptop); would the firewall interfere within a local network? Both computers are behind the same router (I know little about networking ...). Thanks!

gnomesfly gravatar imagegnomesfly ( 2015-05-24 01:37:33 -0500 )edit

Yes the firewall is "on" by default on Fedora. You can turn it off temporarily to see if that solves the problem. Run as root

firewall-cmd --set-default-zone=trusted

If you can connect with VNC now, then it was your firewall that blocked it.

pnadk gravatar imagepnadk ( 2015-05-25 15:33:46 -0500 )edit

Question Tools

Stats

Asked: 2015-05-20 02:00:00 -0500

Seen: 687 times

Last updated: May 20 '15