Ask Your Question
0

WiFi authentication times out

asked 2015-05-06 05:19:43 -0500

Bart Friederichs gravatar image

updated 2015-05-08 02:48:53 -0500

Since today I have this very annoying issue that the WiFi on my HP ProBook is not authenticating anymore. I haven't changed any settings and my mobile phone connects to the WiFi fine. Also trying another WiFi access point (in fact, my mobile phone hotspot) doesn't work.

The scan seems to work, as SSIDs show up fine. Also, if no key is provided, it nicely asks for it. But then, I see this in dmesg:

[ 1854.199036] wlo1: authenticate with 92:68:c3:f4:ec:3a
[ 1854.201743] wlo1: send auth to 92:68:c3:f4:ec:3a (try 1/3)
[ 1854.275690] wlo1: send auth to 92:68:c3:f4:ec:3a (try 2/3)
[ 1854.334745] wlo1: send auth to 92:68:c3:f4:ec:3a (try 3/3)
[ 1854.393245] wlo1: authentication with 92:68:c3:f4:ec:3a timed out

I had the issue on Fedora 20, so I upgraded to 21. Problem remains the same. Even updated to 22 beta, with wpa_supplicant, version 2.3. Same problem.

Update In my attempts to resolve this issue I found some extras:

  • The adapter works fine in Windows 7, so my router and the hardware is fine.
  • I tried to use wpa_cli, but I get the message it cannot connect.
  • The ctrl_interface in wpa_supplicant.conf is not created

In the wpa_supplicant.log, I get this:

wlo1: SME: Trying to authenticate with 00:24:01:df:c2:fb (SSID='MYSSID' freq=2467 MHz)
wlo1: SME: Trying to authenticate with 00:24:01:df:c2:fb (SSID='MYSSID' freq=2467 MHz)
wlo1: SME: Trying to authenticate with 00:24:01:df:c2:fb (SSID='MYSSID' freq=2467 MHz)
wlo1: SME: Trying to authenticate with 00:24:01:df:c2:fb (SSID='MYSSID' freq=2467 MHz)
wlo1: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="MYSSID" auth_failures=1 duration=10 reason=CONN_FAILED

Update Even access points without any encryption are not associated.

edit retag flag offensive close merge delete

Comments

Does your router filter specific MAC addresses or uses channels that your notebook does not support? Also, did you change the MAC address in your question? It does not exist.

mithrial gravatar imagemithrial ( 2015-05-06 12:29:36 -0500 )edit

I didn't change anything at all, except for some updates. I have some connection troubles before, but swtiching the interface off and on again fixed that. About the MAC: it was probably from my cellphone. I see the MAC address of my router in the logs now. Same issue.

Bart Friederichs gravatar imageBart Friederichs ( 2015-05-06 14:25:44 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-05-08 04:52:03 -0500

Bart Friederichs gravatar image

I found the solution here:

echo "options iwlwifi 11n_disable=1 wd_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

Reboot, and it works again.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-06 03:45:30 -0500

Seen: 2,590 times

Last updated: May 08 '15