Ask Your Question

rpm fusion

asked 2015-04-16 18:52:51 -0500

awesomepilot gravatar image

updated 2015-04-17 09:30:02 -0500

mether gravatar image

I have reinstalled fedora 21 x64, and the first time it was installed rpm-fusion worked fine. It actually installed. But this time I just get a message that says "Sorry this did not work". It is really agrivating as I can not install steam or anything else on rpm fusion. It doesen't give me anything to work with except "Sorry this did not work". I am new to fedora, I have never used a non ubuntu system so this is new to me. Right out of the box and im getting errors. I have much to learn about linux.

edit retag flag offensive close merge delete


What exactly did you try doing? and what's the exact error message you got?

Ahmad Samir gravatar imageAhmad Samir ( 2015-04-17 00:49:40 -0500 )edit

Same problem, Aniship's answer worked fine to install steam for me. but started GL2 error, installed i386 nVidia driver package to fix that.

Warren gravatar imageWarren ( 2015-04-17 11:06:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-04-17 06:03:27 -0500

anishjp gravatar image

Well, can you try this as root and let us know?

yum localinstall --nogpgcheck$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm

Then to install steam

yum install steam
edit flag offensive delete link more


Wow! Fantastic, awesome, etc. I usually don't use a lot of adjectives, but... I copied your command into Terminal @ root and and just kept entering Y until all done! Then did the install Steam. Done! Exited Terminal, looked at Activities , and clicked on the Steam icon, voila! I have not logged in yet, have other chores, had to let you know it is exciting to find advice that works. Thanks!

Warren gravatar imageWarren ( 2015-04-17 11:16:53 -0500 )edit

answered 2015-04-18 14:34:02 -0500

Warren gravatar image

Steam on Fedora 21: OpenGL GLX error

After using Aniship's script to install steam, I got OpenGL GLX error, which was fixed following answers at the above query. The final step for me was installing the nVidia 32-bit package. You might want to try that first.

edit flag offensive delete link more

Question Tools



Asked: 2015-04-16 18:52:51 -0500

Seen: 642 times

Last updated: Apr 18 '15