Ask Your Question
0

fedora 22 mysql won't run

asked 2015-04-13 15:26:32 -0500

mkaya gravatar image

updated 2015-04-14 08:48:35 -0500

mether gravatar image

Hi friends, I've upgraded fedora 22.You know, fedora 22 isn't supported yum.So we can use dnf.anyway...

My mysqld service is not working.

[root@localhost msd]# service mysqld start
Redirecting to /bin/systemctl start  mysqld.service
Failed to start mysqld.service: Unit mysqld.service failed to load: No such file or directory.

Can you help.Please ?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-13 17:52:41 -0500

updated 2015-04-13 18:36:28 -0500

Try with:

su -c 'systemctl start mariadb.service'
F19 replaced MySQL with MariaDB: https://fedoraproject.org/wiki/Featur...

edit flag offensive delete link more

Comments

I have tried this.But unfortunately the result is;

[root@localhost msd]# su -c 'systemctl start mariadb.service'
Failed to start mariadb.service: Unit mariadb.service failed to load: No such file or directory.
[root@localhost msd]# 
mkaya gravatar imagemkaya ( 2015-04-13 23:50:57 -0500 )edit

Did you install the DBMS?

su -c 'dnf install -y mysql-server'

rbuj gravatar imagerbuj ( 2015-04-14 02:27:40 -0500 )edit

Yes, I've tried again.But;

[root@localhost msd]# su -c 'dnf install -y mysql-server'
Failed to synchronize cache for repo 'mysql56-community' from 'http://repo.mysql.com/yum/mysql-5.6-community/fc/22/x86_64/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Using metadata from Tue Apr 14 10:14:12 2015 (0:04:20 hours old)
Error: nothing provides perl(Getopt::Long) needed by mariadb-server-1:10.0.17-1.fc22.x86_64
mkaya gravatar imagemkaya ( 2015-04-14 03:19:26 -0500 )edit

Ok, you installed the MySQL using the mysql.com repository, but there isn't any repository for the f22 brach, which is still under development. You can disable the mysql.com repository and use the main fedora repository to avoid that issue. In any case, are you interested in replacing your current DBMS with MariaDB, or you would like to use the Oracle's implementation?

rbuj gravatar imagerbuj ( 2015-04-14 04:13:07 -0500 )edit
su -c 'dnf --releasever=21 distro-sync'
rbuj gravatar imagerbuj ( 2015-04-14 07:30:28 -0500 )edit
0

answered 2015-08-01 03:09:21 -0500

Gautam gravatar image

I also faced same problem for mariadb. To solve i switched to root account :

su

After

systemctl start mariadb

It worked.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-04-13 15:26:32 -0500

Seen: 5,532 times

Last updated: Apr 13 '15