Ask Your Question
0

Error: Cannot retrieve repository metadata

asked 2015-04-10 10:10:53 -0500

sava gravatar image

updated 2015-04-10 15:18:30 -0500

mether gravatar image

Hello Help to understand why the repository does not work

Just installed Fedora 14 (need this version)

"# yum update"

Load modules: langpacks, presto, refresh-packagekit Adding ru_RU to language list Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

Internet, ping - works

Help to understand what is the problem?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-13 11:29:43 -0500

danofsatx gravatar image

Ok, the one error I see is that you left the mirrorlist= line uncommented. I took care of that in the files you linked to. Since this is an EOL release, and there is no update repo for it, you should only have one file: /etc/yum.repos.d/fedora.repo - and it should look like this:

[fedora]
name=Fedora $releasever - $basearch
baseurl=http://dl.fedoraproject.org/pub/archive/fedora/linux/releases/14/Everything/x86_64/os/
enabled=1
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

If you need the Source or Debug repos, add those.

edit flag offensive delete link more

Comments

->danofsatx Thank you very much for the detailed explanation. =)

Did as you wrote yum working.

And I need the current version Fedora 14 as set gcc 4.5.1, which is supported by PostgreSQL 9.0.1. special build for accounting 1C 8. In other, an error, but this is for another topic...

Thank you..

sava gravatar imagesava ( 2015-04-14 13:50:43 -0500 )edit
0

answered 2015-04-10 13:57:09 -0500

Fedora 14 is EOL. Many mirror admins choose not to dedicate their storage and network resources to serving updates for releases that nobody should be using anymore. You really should find another way to meet your needs, that isn't using an EOL Fedora release.

edit flag offensive delete link more

Comments

tell that to your government. sometimes old software has a long shelf life

snakeoil gravatar imagesnakeoil ( 2018-05-09 09:11:45 -0500 )edit
0

answered 2015-04-11 22:14:12 -0500

danofsatx gravatar image

With that said, if you really need to use F14 for a mission critical function, you need to edit the .repo files in /etc/yum.repos.d/.

Within those files, you'll see two lines, one of which is commented out. You will need to comment (or delete) the line starting with metalink= and uncomment the line starting with baseurl=. That line, depending on your architecture, should end up looking like one of these lines:

baseurl=http://dl.fedoraproject.org/pub/archive/fedora/linux/releases/14/Everything/x86_64/os/
baseurl=http://dl.fedoraproject.org/pub/archive/fedora/linux/releases/14/Everything/i386/os/
edit flag offensive delete link more

Comments

Thanks, not works, error persists edited /etc/yum.repos.d/fedora.repos, fedora-updates.repo

edit section repos.d, fedora-updates.repo

[fedora]
[fedora-debuginfo]
[fedora-source]

The entire file:

lrepos.d

fedora-updates.repo

yum.conf

sava gravatar imagesava ( 2015-04-12 23:54:36 -0500 )edit

=) sorry =)

sava gravatar imagesava ( 2015-04-14 03:56:22 -0500 )edit

Question Tools

Stats

Asked: 2015-04-10 10:10:53 -0500

Seen: 8,765 times

Last updated: Apr 10 '15