Ask Your Question
0

slow internet on fedora 21

asked 2015-04-10 06:50:46 -0500

mrsokrat08 gravatar image

updated 2015-04-11 11:51:26 -0500

mether gravatar image

Iam a new user for linux my problem is that tha internet is very slow on fedora 21 comparing to windows 7 so my teachet advice me to get my network wired card and wireless card information and then ask you for the proper command to install the proper devices so :

Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe 05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Contro

thanks :)

edit retag flag offensive close merge delete

Comments

Do youhave installed rpmfusion.org fedora repo, if not do that and search for module for your nic there.

aeperezt gravatar imageaeperezt ( 2015-04-10 09:31:06 -0500 )edit

Can you do a speedtest on windows and linux and provide us with those values

lnxslck gravatar imagelnxslck ( 2015-04-10 10:54:20 -0500 )edit

thanks for replay - but iam still confused - my engilish isnot so good - and there are alot of links there what should i do ?!

mrsokrat08 gravatar imagemrsokrat08 ( 2015-04-10 10:59:11 -0500 )edit

ok go here http://rpmfusion.org/Configuration then download and install http://download1.rpmfusion.org/free/f... and http://download1.rpmfusion.org/nonfre...

then you can use yum search RT3290 to see if you find a module for your card

aeperezt gravatar imageaeperezt ( 2015-04-10 14:33:30 -0500 )edit

if you run the command echo 'nameserver 8.8.8.8.' | sudo tee /etc/resolv.conf does it improve?

randomuser gravatar imagerandomuser ( 2015-04-10 15:33:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-10 17:13:23 -0500

matachi gravatar image

Have you ran a system update?

After I installed Fedora 21 on my Thinkpad T440 laptop, my Wi-Fi speed was extremely slow. I had to plug in an Ethernet cable to be able to use the Internet. However, after doing a system update over the Ethernet connection and rebooting the computer, the Wi-Fi worked great.

To update Fedora, do the following steps:

  1. Press Activities in the upper-left corner of the screen. Search for "software":

    image description

  2. Open the program Software:

    image description

  3. Visit the Updates tab where you are able to update the system:

    image description

I can't guarantee that this will solve your problem. However, it did it for me and I think it's a good starting point for solving the problem. But regardless, it's always good to run up-to-date software.

edit flag offensive delete link more

Comments

i did that but i found that all software are up to date

mrsokrat08 gravatar imagemrsokrat08 ( 2015-04-12 09:27:51 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-04-10 06:50:46 -0500

Seen: 993 times

Last updated: Apr 10 '15