Ask Your Question

Disable Automatic Update Check

asked 2015-04-04 02:36:52 -0500

Phx_01 gravatar image

updated 2015-04-04 10:22:58 -0500

mether gravatar image

As of recent, I am on a mobile Internet connection (3G/4G) and have a limited allowance of 30 GB per month. To my surprise, compared to my regular usage before (16-22 GB/month) I am now using between 250 MB - 1.5 GB a day with about 500 MB being the average.

Using System Monitor just after start, I saw spikes going up downloading between 75 MB - 200 MB in one chunk before calming down again. A similar spike can be seen when going to Settings > Details, which makes me believe that checking for Software Updates is the main culprit here (there might be more though).

How do I get this under control? Is there a way to a) check which service/application is using that much traffic and b) is there a way to just disable it?

Software Updates do not need to be checked automatically for me as I am using YumEx often enough to check for updates manually.

I found two related threads: How to disable automatic updates in Fedora 20? and How do automatic checking of updates work (package-kit?)?, but was unable to make out whether this also addresses the checking itself. Additionally, there may be other background tasks eating up my allowance, which are not addressed by those threads.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-04-04 09:15:06 -0500

ageha gravatar image

I disabled the gnome update check with:

gsettings set download-updates false

That seems to have "fixed" it.

edit flag offensive delete link more


Thanks for the command! I just put it in and will now monitor how it goes. Will mark-as-correct once verified.

Phx_01 gravatar imagePhx_01 ( 2015-04-05 03:20:12 -0500 )edit

Appears to have worked. Thanks a lot!

Phx_01 gravatar imagePhx_01 ( 2015-04-10 14:06:56 -0500 )edit

Question Tools

1 follower


Asked: 2015-04-04 02:36:52 -0500

Seen: 3,624 times

Last updated: Apr 04 '15