Ask Your Question

Applications' Audio (again)

asked 2015-04-01 11:11:13 -0500

Marzian gravatar image

Hello, I'm having again the same issue addressed here:

But this time the workaround I found previously is not helping anymore.

HDMI works fine, but the speakers' audio doesn't.

Could someone help me? Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-04-07 04:36:21 -0500

Marzian gravatar image

updated 2015-04-07 04:36:55 -0500

Apparently, I've been able to fix it this way:

  • Set "autospawn=no" in ~/.pulse/client.conf permanently (do not remove the file or the line, or set it to "yes", as I did the previous time after it started to work)

  • Add a "pulseaudio.desktop" file in ~/.config/autostart with this content:

[Desktop Entry]



Comment=Start this up at login





edit flag offensive delete link more

answered 2015-04-07 13:16:17 -0500

passthejoe gravatar image

In Xfce, I find that you can control the output (and input) of PulseAudio much better with the PulseAudio Volume Control application -- . I have that in my dock, and I use it all the time to switch the output between the laptop speakers and HDMI.

In GNOME, I use the Volume Mixer GNOME Extension to do the same thing from the upper panel:

You could get along with pavucontrol for both GNOME and non-GNOME desktop environments, but I find that it's useful to use Volume Mixer in GNOME and pavu in other desktops.

edit flag offensive delete link more


I forgot to write it, but you have correctly grasped that my issue probably started while switching between HDMI and speakers... I had discovered pavucontrol while trying to find a solution, but I didn't know about the Volume Mixer Extension: thanks for the tip.

Marzian gravatar imageMarzian ( 2015-04-07 15:17:16 -0500 )edit

Question Tools

1 follower


Asked: 2015-04-01 11:11:13 -0500

Seen: 81 times

Last updated: Apr 07 '15