Ask Your Question

How to disable Nouveau, and install Nvidia.

asked 2015-03-29 19:15:16 -0500

mikaelbrun gravatar image

updated 2015-03-30 05:29:04 -0500

FranciscoD_ gravatar image

I installed Fedora 21 a week ago. The first impression was very good, and still is.

Some problems occurred, and I had to make a reinstall. The last install, I also installed Nvidia drivers, with a little help from google. But then my wifi crashed, and I made a new install. Now I'm not able to install Nvidia, because of the nouveau driver. I can't remember what I did last time (I will make a guide next time :-) ), so I need some help.

This has been done (all in su)

yum install gcc kernel-devel

gedit /etc/modprobe.d/blacklist.conf
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

gedit /etc/sysconfig/grub
added rd.driver.blacklist=nouveau in the GRUB_CMDLINE_LINUX= 

grub2-mkconfig -o /boot/grub2/grub

grub2-mkconfig -o /boot/efi/EFI/fedora/grub    (I don't know which is used)

yum remoce xorg-x11-drv-nouveau.x86_64

mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

dracut /boot/intirams-$(uname -r).img $(uname -r)

systemctl set-default

Well that's about it. What have I forgot, or what have I gone wrong?

I will reinstall and update fedora 21. A step by step instruction would have been nice :-)

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2015-03-30 04:32:42 -0500

matachi gravatar image

updated 2015-03-30 09:35:09 -0500

The third-party repository RPM Fusion contains binaries for Nvidia's proprietary drivers, which are very easy to install. See the page for complete instructions on how to install them.

In my own desktop pc I have an Nvidia 660, and I'm running Fedora 21 Workstation with Nvidia's proprietary drivers. To install the drivers, i did:

  1. Enable (at least) nonfree RPM Fusion, see
  2. Install the drivers:

    $ sudo dnf install xorg-x11-drv-nvidia

    See for more information.

  3. If you plan on playing games on Steam etc, you probably also need the 32-bit version of the drivers:

    $ sudo dnf install xorg-x11-drv-nvidia-libs.i686

edit flag offensive delete link more



RPMFusion actually has a page dedicated to Nvidia installation here - you could just point to it in your answer instead of restating what it already has. (Each time the information is restated, there are chances of an error creeping in.)

FranciscoD_ gravatar imageFranciscoD_ ( 2015-03-30 05:28:29 -0500 )edit

@FranciscoD_, good point. I have updated my answer to also refer to that link.

matachi gravatar imagematachi ( 2015-03-30 09:34:19 -0500 )edit

Above method did not worked for me . I am using Fedora 23 . This make me to stuck at login screen !

JAC_just_another_coder gravatar imageJAC_just_another_coder ( 2016-01-10 03:59:01 -0500 )edit

answered 2015-05-27 13:15:05 -0500

mikaelbrun gravatar image

I forgot to thank you all for the help. Thank you!

edit flag offensive delete link more



Don't forget to accept the right answer by clicking on the gray check-mark

florian gravatar imageflorian ( 2015-05-27 22:05:42 -0500 )edit

answered 2015-06-11 12:23:12 -0500

RogerP gravatar image

Too bad rpmfusion has nothing for tesla cards. :-( Roger

edit flag offensive delete link more

Question Tools



Asked: 2015-03-29 19:15:16 -0500

Seen: 51,948 times

Last updated: May 27 '15