Ask Your Question
2

VMware Workstation 11 fails to build vmnet on Fedora 21

asked 2015-03-23 23:22:19 -0500

Kyte gravatar image

updated 2015-03-24 05:32:06 -0500

cobra gravatar image

I was finally able to get VMware workstation installed on my Linux machine (in which I am still a newb) this means getting all the kernel-headers correct, etc. However now when I try and open for the first time and it tries to build the modules it fails every time at the vmnet. I have attached the failure log it produced. If anyone know of a patch for Fedora 21 and VMware 11 please let me know!

2015-03-23T19:49:28.782-07:00| vthread-4| I120: Log for VMware Workstation pid=6969 version=11.0.0 build=build-2305329 option=Release
2015-03-23T19:49:28.782-07:00| vthread-4| I120: The process is 64-bit.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: Host codepage=UTF-8 encoding=UTF-8
2015-03-23T19:49:28.782-07:00| vthread-4| I120: Host is Linux 3.19.1-201.fc21.x86_64 Fedora release 21 (Twenty One)
2015-03-23T19:49:28.782-07:00| vthread-4| I120: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: Msg_Reset:
2015-03-23T19:49:28.782-07:00| vthread-4| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: ----------------------------------------
2015-03-23T19:49:28.782-07:00| vthread-4| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: DictionaryLoad: Cannot open file "/root/.vmware/config": No such file or directory.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: Msg_Reset:
2015-03-23T19:49:28.782-07:00| vthread-4| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: ----------------------------------------
2015-03-23T19:49:28.782-07:00| vthread-4| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: PREF Unable to check permissions for preferences file.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: DictionaryLoad: Cannot open file "/root/.vmware/preferences": No such file or directory.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: Msg_Reset:
2015-03-23T19:49:28.782-07:00| vthread-4| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory.
2015-03-23T19:49:28.782-07:00| vthread-4| I120: ----------------------------------------
2015-03-23T19:49:28.782-07:00| vthread-4| I120: PREF Failed to load user preferences.
2015-03-23T19:49:28.800-07:00| vthread-4| W110: Logging to /tmp/vmware-root/vmware-6969.log
2015-03-23T19:49:28.844-07:00| vthread-4| I120: Obtaining info using the running kernel.
2015-03-23T19:49:28.844-07:00| vthread-4| I120: Created new pathsHash.
2015-03-23T19:49:28.845-07:00| vthread-4| I120: Setting header path for 3.19.1-201.fc21.x86_64 to "/lib/modules/3.19.1-201.fc21.x86_64/build/include".
2015-03-23T19:49:28.845-07:00| vthread-4| I120: Validating path "/lib/modules/3.19.1-201.fc21.x86_64/build/include" for kernel release "3.19.1-201.fc21.x86_64".
2015-03-23T19:49:28.845-07:00| vthread-4| I120: Failed to find /lib/modules/3.19.1-201.fc21.x86_64/build/include/linux/version.h
2015-03-23T19:49:28.845-07:00| vthread-4| I120: /lib/modules/3 ...
(more)
edit retag flag offensive close merge delete

Comments

It's trying to execute the 'make' command, and it's failing with an error about the build command. You do have 'make' installed, don't you? The script does lots of checks of paths and tools, including gcc, but I can't see a check for 'make' anywhere.

cobra gravatar imagecobra ( 2015-03-24 05:39:00 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-03-25 20:09:10 -0500

Kyte gravatar image

I did use that thread, but I shall type out the commands that I had to use to make VMware Workstation work on my machine.

$ curl http://pastie.org/pastes/9934018/download -o /tmp/vmnet-3.19.patch
$ cd /usr/lib/vmware/modules/source
# tar -xf vmnet.tar
# patch -p0 -i /tmp/vmnet-3.19.patch
# tar -cf vmnet.tar vmnet-only
# rm -r *-only
# vmware-modconfig --console --install-all

After I did these steps I was able to run VMware Workstation without any problems.

edit flag offensive delete link more

Comments

Extremely useful. Thank you for this.

lokoalex gravatar imagelokoalex ( 2015-04-03 10:33:30 -0500 )edit

This worked great for me. Thank you!

Ciscomastermind gravatar imageCiscomastermind ( 2015-04-10 12:36:37 -0500 )edit

This fixed it for me. Thank you!

Ciscomastermind gravatar imageCiscomastermind ( 2015-04-10 12:37:42 -0500 )edit

Perfecto funciono para mi.

Alex Marcovich gravatar imageAlex Marcovich ( 2015-05-11 15:24:20 -0500 )edit

Worked like a breeze. Thank you.

mmo gravatar imagemmo ( 2015-05-13 07:05:54 -0500 )edit
3

answered 2015-03-24 11:40:13 -0500

jimmychanga gravatar image

I have the same issue. Found this article and it helped. http://forums.fedoraforum.org/showthr...

edit flag offensive delete link more

Comments

The link was very helpful but it is subject to link rot. I would suggest copy/paste some of the essential lines in this answer.

Sardathrion gravatar imageSardathrion ( 2015-03-25 03:06:50 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-23 23:22:19 -0500

Seen: 12,378 times

Last updated: May 11 '15