Ask Your Question
0

Fedora 21 problem with line 31of kickstart

asked 2015-03-23 16:43:26 -0500

husker502 gravatar image

updated 2015-03-23 22:14:14 -0500

mether gravatar image

When I try to install Fedora 21 on VMware workstation 11 I get the following messages.

anaconda 21.48.21-1 for Fedora-Server 21 started. The following problem occurred on line 31of the kickstart file: Section %packages does not end with %end.

I don't get a command prompt($) and also I am a novice at Linux so I'm stuck. I tried control -c and also control z to break the process but no luck. Any suggestions?

edit retag flag offensive close merge delete

Comments

Well...what's your kickstart file look like?

bitwiseoperator gravatar imagebitwiseoperator ( 2015-03-23 16:48:02 -0500 )edit

yeah "past in" your kickstart please

sergiomb gravatar imagesergiomb ( 2015-03-24 07:55:42 -0500 )edit

I'm a bit lost. I'm running VMware on a windows machine. VMware prompts me for the location of the iso file and then starts the install process. The install process freezes on the error above and I'm unable to navigate on the fedora server so I can't find my kickstart.cfg file to edit it and make the change on line 31. I'm assuming I can't change the iso file prior to the install process.

husker502 gravatar imagehusker502 ( 2015-03-24 13:55:07 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-03-24 16:23:45 -0500

Looks like you're running into this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1173014

Try Gert Marissen's workaround. Stub out a Fedora 64 bit virtual machine in VMware with an empty virtual hard disk, doing nothing else, and then load the ISO and see if it works.

edit flag offensive delete link more
0

answered 2015-03-30 22:33:53 -0500

jefby gravatar image

when boot message is displayed,you can type "e" to view the kickstart file ,maybe your kickstart file is some wrong ,below is my kickstart file:

    #version=DEVEL
    # System authorization information
    auth --enableshadow --passalgo=sha512

    # Use network installation
    url --url="ftp://192.168.0.1/os"
    # Use text mode install
    text
    # Run the Setup Agent on first boot
    firstboot --enable
    ignoredisk --only-use=sda,sdb
    # Keyboard layouts
    keyboard --vckeymap=us --xlayouts='us'
    # System language
    lang en_US.UTF-8

    # Network information
    network  --bootproto=dhcp --device=eth0 --ipv6=auto --activate
    network  --bootproto=dhcp --hostname=localhost.localdomain
    # Root password
    rootpw --iscrypted $6$27GkSwEjMzfYoeTl$Um2RL3MHEz1NDfo3h.sqOmroIRuS2dPUc3bQHJVkon4SxI4zhLu3aQ5KdCdU2W0CD0peivNGZSzfWpBUqH/9f1
    # SELinux configuration
    selinux --disabled
    # Do not configure the X Window System
    skipx
    # System timezone
    rootpw --iscrypted $6$27GkSwEjMzfYoeTl$Um2RL3MHEz1NDfo3h.sqOmroIRuS2dPUc3bQHJVkon4SxI4zhLu3aQ5KdCdU2W0CD0peivNGZSzfWpBUqH/9f1
    # Do not configure the X Window System
    skipx
    # System timezone
    timezone Asia/Hong_Kong --isUtc
    # System bootloader configuration
    bootloader --location=mbr --boot-drive=sda
    autopart --type=lvm
    # Partition clearing information
    clearpart --all --initlabel --drives=sda,sdb

    %packages
    @container-management
    @core
    @domain-client
    @hardware-support
    @headless-management
    @server-product
    @standard

    %end
    # Reboot after installation
    reboot
edit flag offensive delete link more
0

answered 2015-04-14 14:02:25 -0500

estava com esse mesmo problema no vmware, basta você iniciar uma virtualização custo typical ou custom e não escolher a opção image, use a installer disc, só pra burlar o bug do vmware, e marca que opção i will install the operating system later. Informe o sistema linux e versão fedora. Depois disso edite as configurações do virtual para executar a imagem e inicie o virtual

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-03-23 16:43:26 -0500

Seen: 611 times

Last updated: Mar 24 '15