Ask Your Question
1

F21 emergency mode

asked 2015-03-14 16:37:50 -0500

G sus gravatar image

updated 2015-04-08 13:01:17 -0500

Hi folks,

My computer (F21 on Lenovo Thinkcentre) is booting into emergency mode and I need to ctrl-D to move on each time. I have had trouble with an external harddrive seizing the system on boot but have stopped using it - perhaps related?

Before it gets to the sign in section it gives me

[24 etc ] systemd-fsck[610] /dev/mapper/fedora_localhost-home: clean 203/36732 etc blocks

I dropped down two kernal layers and updated the system but no change after reboot.

Any help appreciated.

Geoff.

From journalctl -b output:

Mar 27 12:37:56 localhost.telecom systemd-fsck[483]: /dev/mapper/fedora_localhost-root: Superblock last write time is in the future.
Mar 27 12:37:56 localhost.telecom systemd-fsck[483]: (by less than a day, probably due to the hardware clock being incorrectly set).  FIXED.
Mar 27 12:37:57 localhost.telecom lvm[480]: 2 logical volume(s) in volume group "fedora_localhost" monitored
Mar 27 12:38:00 localhost.telecom systemd-fsck[483]: /dev/mapper/fedora_localhost-root: Inodes that were part of a corrupted orphan linked list found.
Mar 27 12:38:00 localhost.telecom systemd-fsck[483]: /dev/mapper/fedora_localhost-root: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
Mar 27 12:38:00 localhost.telecom systemd-fsck[483]: (i.e., without -a or -p options)
edit retag flag offensive close merge delete

Comments

Do you have an entry for the old hard drive in /etc/fstab?

randomuser gravatar imagerandomuser ( 2015-03-14 17:28:27 -0500 )edit

well this is still happening a few weeks later.

Sorry Randomuser but I'm not a technical user and your question makes no sense to me. i need step-by-step assistance. Thank you

G sus gravatar imageG sus ( 2015-03-26 12:46:28 -0500 )edit

No worries, we can help track it down. As soon as you get the system booted, open a terminal window and run the command journalctl -b | fpaste (hopefully it won't be too big!). Share the link that the command gives you.

randomuser gravatar imagerandomuser ( 2015-03-26 14:03:52 -0500 )edit

Kia ora,

here is the link generated by the terminal:

http://paste.fedoraproject.org/203559/13513142

thanks for the help!

G sus gravatar imageG sus ( 2015-03-26 18:49:52 -0500 )edit

hello! Still happening... still need help! F21 is looking like a real pain! Should have stayed with LTS!

G sus gravatar imageG sus ( 2015-04-08 05:20:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-08 13:10:59 -0500

You have a corrupted filesystem that the automatic check cannot repair.

The most common causes of this are either powering off the machine improperly or physical defects in the drive. You should know if it shuts down properly (ie you don't have to pull the plug for the computer to turn off), and you can use gnome-disks to check the drive health. If you aren't sure about the drive health info, do smartctl -a /dev/sda | fpaste and share the link.

There are notes about things dated in the future. Make sure your computer's clock is set correctly. chrony will do this automatically for you on Fedora, and you can use sudo timedatectl to adjust the system clock depending on if it is UTC time or your local timezone. Read man timedatectl and ask if you think it needs adjustment and you aren't sure what to do.

That said, I think doing a more thorough filesystem check should resolve the problem. Like the log says, you need to run fsck manually. Since this is your root filesystem, and it cannot check itself, you will have to use a live image. sudo fsck /dev/mapper/fedora_localhost-root from a live image should repair it; if not, let us know.

edit flag offensive delete link more

Comments

Thanks for getting back :)

Here is the link generated by the smartctl command:

http://paste.fedoraproject.org/208726...

Ill look into the rest. Is gnome-disks a programme? I'll search for it. The likelihood of an improper shutdown is pretty high as I had a an external harddrive that would freeze the system and nothing worked but to shut it down by crashing (no mouse or keyboard response). This is still a problem but I've stopped using that drive (it works fine on my F20 though!).

Thanks again for your help.

G sus gravatar imageG sus ( 2015-04-08 18:05:15 -0500 )edit

disks is not very user-friendly is it? no idea what to do with it sorry, but it's there.

G sus gravatar imageG sus ( 2015-04-08 18:12:28 -0500 )edit

TIMEDATECTL(1) timedatectl TIMEDATECTL(1)

NAME timedatectl - Control the system time and date

SYNOPSIS timedatectl [OPTIONS...] {COMMAND}

DESCRIPTION timedatectl may be used to query and change the system clock and its settings.

   Use systemd-firstboot(1) to initialize the system time zone for mounted
   (but not booted) system images.

OPTIONS The following options are understood:

   --no-ask-password
       Do not query the user for authentication for privileged operations.

   --adjust-syste
G sus gravatar imageG sus ( 2015-04-08 18:18:50 -0500 )edit

Hi,

fsck questions: I need to download a f21 iso? boot the system from this image (on a usb or disk), open a terminal and run that command? Far out! I upraded from f20 so no iso used.

G sus gravatar imageG sus ( 2015-04-08 18:31:06 -0500 )edit

For gnome-disks, click the drive, then the menu button (three horizontal lines) and choose the "SMART Data and Self Tests". It shows the same metrics as smartctl, but also helpful assessment.

You should be able to do the fsck from any modern linux live image.

randomuser gravatar imagerandomuser ( 2015-04-08 18:40:49 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-14 16:37:50 -0500

Seen: 8,063 times

Last updated: Apr 08 '15