Ask Your Question
0

Can't Access tty Console or Runlevel 3 but Runlevel 5 Works Fine

asked 2015-03-11 21:28:56 -0500

cgonz31 gravatar image

updated 2015-03-22 19:42:08 -0500

System boots straight to GNOME. Everything works fine in init 5. Ctrl-Alt-F2 to switch to console yields the following error:

[ 1.365779] ata8.00: exception Emask 0x1 SAct 0x0 SErr 0x0 action 0x0
[ 1.365854] ata8.00: irq_stat 0x40000001

If I press Ctrl-Alt-F1, I can get back to GNOME.

Same error shows if I am in GNOME and run sudo init 3 in a terminal but I can't get back to GNOME. As pointed out by ramdomuser in the comments, this is normal since I just killed the graphical interface. I have to restart my system.

I looked up the error and it seems that it is associated with failing hard drives. I doubt this is my case. I have a 2-year-old SSD and 2 brand new (a week old) HDDs. The error was present before I installed the new HDDs. Also recent disk checks with GNOME Disks and fsck on all three drives turn up no errors. No warning in the SMART data, either.

I dual boot with RHEL Workstation 6.6 and init 3 works fine in there.

In Fedora, I suspect it is an NVIDIA (GTX 560 Ti) issue because I can't access init 3 or the tty console with the regular kernels. But if I boot with the rescue kernel (which uses nouveau), init 3 works fine. I am using the drivers from RPM Fusion.

Any help would be appreciated.

EDIT:

I tried waiting after pressing Ctrl-Alt-F2 -> Still stuck after 1 hour. Ctrl-Alt-F1 brought me back to GNOME.

I tried waiting after pressing issuing sudo init 3 in a GNOME terminal -> Still stuck after 1 hour. Had to reboot.

I also tried verbose booting into init 3 by editing the kernel parameters in grub. The system was stuck at Reached target Slices. Had to reboot after 1 hour.

EDIT 2:

Output of journalctl -b -1. This is the boot log for the time I tried to boot into init 3 by changing the kernel parameters in grub. I also confirmed this is the right boot log. journalctl -b -1 |grep gdm gives no output which means the system never reached init 5.

https://drive.google.com/file/d/0B8BdgE0EHPlFQ2RVbngtT3Q1UTQ/view?usp=sharing

EDIT 3:

I backed up my current initramfs image and regenerated the image with sudo dracut /boot/initramfs-$(uname -r).img $(uname -r). Rebooted into init 5. Tried Ctrl-Alt-F2. Still stuck. Then I specifically tried omitting the nouveau drivers with sudo dracut --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r). Still stuck.

edit retag flag offensive close merge delete

Comments

1

You should read over https://fedoraproject.org/wiki/SysVinit_to_Systemd_Cheatsheet . The command init still does something, but probably not what you think, it's only there for backwards compatibility reasons. For the last several years, this would map to systemctl isolate multi-user.target

This part stands out to me: " I am in GNOME and run sudo init 3 in a terminal but Ctrl-Alt-F1 does not bring me back to GNOME. " - What you are saying here is "I took the system out of the graphical runlevel, and my graphical session was no longer running" - this is expected. Not spaning gettys on TTYs is not expected, though.

If the rescue initramfs works, try sudo dracut --regenerate-all to rebuild all the others. The HDD error shows on the console because that type of error shows on the console, I don't think it is a factor in gettys not spawning. The journal output from ...(more)

randomuser gravatar imagerandomuser ( 2015-03-14 13:16:28 -0500 )edit

You are correct in your comment about me killing the graphical runlevel. I edited the question to correct this. Thanks for pointing it out.

I will try running the systemctl isolate multi-user.target command. I will also try regenerating the initramfs and rebooting. I have posted the journal output in the question.

cgonz31 gravatar imagecgonz31 ( 2015-03-14 14:10:36 -0500 )edit

As I'm skimming through, I see complaints about a line in /etc/fstab. Probably not related - depending on the mount point in question - but you should check into it.

randomuser gravatar imagerandomuser ( 2015-03-14 15:10:13 -0500 )edit

I also see " nmbd[1290]: WARNING: Ignoring invalid value 'share' for parameter 'security' " - it would be a good idea to adjust your smb.conf for the current version of samba.

randomuser gravatar imagerandomuser ( 2015-03-14 15:13:11 -0500 )edit

I also see you have a public IP on this box - it would be a good idea to read up on firewalld and add your internal subnet to a less restrictive zone, and set the default zone to something very restrictive.

randomuser gravatar imagerandomuser ( 2015-03-14 15:16:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-22 19:06:29 -0500

cgonz31 gravatar image

I have a second PC with an Nvidia card and F21 and using the RPM Fusion drivers. This PC (PC 2) has normal tty and runlevel 3 behavior.

I compared the configuration files in my problematic PC (PC 1) and PC 2. The /etc/default/grub file was the culprit. PC 1 did NOT have the nomodeset kernel parameter while PC 2 did have it. Thus I added the nomodeset parameter to GRUB2 in PC 1 and ran sudo grub2-mkconfig -o /boot/grub2/grub.cfg.

Simple as that. Now I can reach the tty consoles and runlevel 3. As an added bonus, I got the Plymouth theme back.

NOTE:

For whatever reason, the nomodeset parameter was NOT added during the RPM Fusion Nvidia driver installation on PC 1 but was added for PC 2. I thought nomodeset was only needed for the proprietary Nvidia driver.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-03-11 21:28:56 -0500

Seen: 1,688 times

Last updated: Mar 22 '15