Ask Your Question
0

fedora packager is not installed on fedora 21

asked 2015-03-09 13:05:21 -0500

Behrooz gravatar image

updated 2015-03-10 16:17:31 -0500

mether gravatar image

Hello everyone I want install fedora packager on fedora 21 but it is not installed . yum give me this error .

link text

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2015-03-09 13:42:40 -0500

darakus gravatar image

Looks like the version of rpm from updates-testing repo is newer than the version of rpm-build that your getting from updates repo. Chances are good that the newer version of rpm-build will be pushed to updates-testing soon and the error will work itself out. Otherwise you could disable updates-testing and install the matching version of rpm.

Hope that helps.

edit flag offensive delete link more
1

answered 2015-03-09 13:37:50 -0500

cobra gravatar image

The error you see is that your installed version of RPM is too new. This can be caused by several issues. Here's one or two things check:

  • That you don't have the development repositories enabled - if you have rawhide turned on, you may get newer versions of some packages
  • That you've not added or enabled a different repository that has upgraded your rpm package preventing this from working
  • That the repository providing the Fedora Package package is the official one. If it isn't you could be installing the wrong version which is relying on old or out of date dependencies.

If none of these resolve the problem, you might even find that there has been a problem with the package build, and that an old version is available through the official repositories in error. If this is the case, you might want to give them packagers a day or so to see if they resolve this, and if not, raise a package bug.

edit flag offensive delete link more
0

answered 2015-03-10 01:21:54 -0500

Behrooz gravatar image

Thnak you everone i disable updates-testing and downgrade rpm then install fedora packager .

edit flag offensive delete link more

Comments

Don't forget to select this answer as correct. That's the best way to tell everybody what the right answer is. And, what you want is [Solved] not [Closed] as only a moderator can close a question.

sideburns gravatar imagesideburns ( 2015-03-10 14:02:26 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-09 13:05:21 -0500

Seen: 205 times

Last updated: Mar 10 '15