Ask Your Question
0

delete skype

asked 2015-02-25 04:09:23 -0500

Programmer gravatar image

how can i delete skype ?!

edit retag flag offensive close merge delete

Comments

How did you install it? If there was an install script that you ran, then there's quite often an uninstall mechanism attached to that script, you'd just run that with the appropriate command line option.

cobra gravatar imagecobra ( 2015-02-25 04:16:28 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-25 04:40:01 -0500

Programmer gravatar image

updated 2015-02-25 07:18:48 -0500

cobra gravatar image

i install that with this command :

sudo gedit /etc/yum.repos.d/skype.repo

[skype]

name=Skype Repository

baseurl=http://download.skype.com/linux/repos/fedora/updates/i586/

gpgkey=http://www.skype.com/products/skype/linux/rpm-public-key.asc

then when run any command terminal give me this err

File contains parsing errors: file:///etc/yum.repos.d/skype.repo [line 5]: name=Skype Repository

[line  7]:     baseurl=http://download.skype.com/linux/repos/fedora/updates/i586/

[line  9]:     gpgkey=http://www.skype.com/products/skype/linux/rpm-public-key.asc

when run yum install skype after downloadding some package give me these err :

Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libasound.so.2(ALSA_0.9)
Error: Package: mesa-libGL-10.4.3-1.20150124.fc21.i686 (updates)
           Requires: libXext.so.6
Error: Package: 1:qt-4.8.6-18.fc21.i686 (updates)
           Requires: libgthread-2.0.so.0
Error: Package: 1:openssl-libs-1.0.1k-1.fc21.i686 (updates)
           Requires: libk5crypto.so.3
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libpng16.so.16
Error: Package: mesa-libGL-10.4.3-1.20150124.fc21.i686 (updates)
           Requires: libselinux.so.1
Error: Package: 1:openssl-libs-1.0.1k-1.fc21.i686 (updates)
           Requires: libgssapi_krb5.so.2
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libglib-2.0.so.0
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libfontconfig.so.1
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libXrandr.so.2
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libSM.so.6
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libXext.so.6
Error: Package: sqlite-3.8.8-2.fc21.i686 (updates)
           Requires: libtinfo.so.5
Error: Package: 1:openssl-libs-1.0.1k-1.fc21.i686 (updates)
           Requires: libk5crypto.so.3(k5crypto_3_MIT)
Error: Package: 1:qt-4.8.6-18.fc21.i686 (updates)
           Requires: libz.so.1
Error: Package: sqlite-3.8.8-2.fc21.i686 (updates)
           Requires: libncurses.so.5
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libXfixes.so.3
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libXinerama.so.1
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libasound.so.2(ALSA_0.9.0rc4)
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libXrender.so.1
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libmng.so.2
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libz.so.1
Error: Package: mesa-libGL-10.4.3-1.20150124.fc21.i686 (updates)
           Requires: libX11.so.6
Error: Package: mesa-libGL-10.4.3-1.20150124.fc21.i686 (updates)
           Requires: libX11-xcb.so.1
Error: Package: skype-4.3.0.37-2.R.i586 (russianfedora-nonfree)
           Requires: libX11.so.6
Error: Package: sqlite-3.8.8-2.fc21.i686 (updates)
           Requires: libreadline.so.6
Error: Package: skype-4.3.0.37-2.R.i586 (russianfedora-nonfree)
           Requires: libQtWebKit.so.4
Error: Package: mesa-libGL-10.4.3-1.20150124.fc21.i686 (updates)
           Requires: libXxf86vm.so.1
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libgobject-2.0.so.0
Error: Package: 1:qt-x11-4.8.6-18.fc21.i686 (updates)
           Requires: libasound.so.2
Error: Package: mesa-libglapi-10 ...
(more)
edit flag offensive delete link more

Comments

2

Is skype installed then? Did you run yum install skype after adding this repository file?

If you're trying to add skype to your package manager by adding the repository, this doesn't install the app on its own, you'd have to use the package manager after adding the repository to add the application.

The error says you have a problem in the repository file, so you probably haven't even got the skype package on yet. What happens if you run, from the command line, rpm -qa | grep skype?

cobra gravatar imagecobra ( 2015-02-25 04:46:24 -0500 )edit
0

answered 2015-02-25 10:06:20 -0500

deusdara gravatar image

Hi

First step

Log into a terminal as root (su or su -)

And use

yum remove skype

yum rm /etc/yum.repos.d/skype.repo

in order to remove the old Skype version and the repository information in /etc/yum.repos.d

Second step

Skype Automatic Installation

easyLife allows new and even experienced users to install and configure software on Fedora, just by clicking. It's simple and clean. Among others, these are some of easyLife features:

Sets "sudo" command up for your regular user;

Configures RPMFusion repository for extra and non-free software;

Installs Flash Player plugin;

Installs all kinds of Codecs (h264,divx,xvid,mp3 etc);

Installs nvidia and ati drivers;

Installs Skype;

http://easylifeproject.org/

Or Skype Manual Installation

Install Skype 4.3 on Fedora 21/20, CentOS/RHEL/SL 7/6.6

http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/

edit flag offensive delete link more
0

answered 2015-02-25 07:22:16 -0500

cobra gravatar image

That output tells you that skype is not installed and fails to install.

If you want to delete skype, as your question asks, then just delete the skype.repo file and your system will no longer try to check this repository when doing an update.

If you want to get skype installed, then the missing packages may be available in the rpmfusion.org repository. Visit their website, follow the simple instructions to add both the free and non-free repositories then retry your skype install.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-02-25 04:09:23 -0500

Seen: 3,567 times

Last updated: Feb 25 '15