Ask Your Question

Fedora 21 Boots To Black Screen

asked 2015-02-23 18:17:01 -0500

Split826 gravatar image

updated 2015-02-23 22:40:26 -0500

mether gravatar image

I have just installed Fedora 21 successfully. After selecting my os in the GRUB menu, i am taken to a black screen.
My monitor is receiving a live feed, it's just black.

Interestingly enough, when my computer recovers from sleep mode, i can see a screen, but as soon as i press a button, the screen goes black again.

Any guidance is appreciated here.

Here is my hardware type:

edit retag flag offensive close merge delete


Can you boot into recovery mode? Hold shift pressed before Grub loads.

florian gravatar imageflorian ( 2015-02-23 20:39:55 -0500 )edit

Holding shift didnt do anything for me. I tried pressing it very quickly and it takes me to a menu that says "setparams 'Fedora, with Linux 3.17.4-301.xxxxx yada yada.

I assume this is not recovery mode.

Split826 gravatar imageSplit826 ( 2015-02-24 14:45:50 -0500 )edit

No i cannot. Holding shift yields no different outcome.

Split826 gravatar imageSplit826 ( 2015-02-24 15:06:18 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2015-02-25 14:13:26 -0500

Split826 gravatar image

Alright i figured out the problem, but i could still use some help here.

My Zotac PC has 2 display ports 1 is HDMI, 1 is DVI. I have been using DVI. For fun i plugged in the HDMI, where i found a login prompt waiting for me.

SO it turns out that the DVI link is just a screen extension of the HDMI port.

My problem now is that i cant figure out how to force the login prompt to the DVI monitor. I have changed my screen in the "Displays" Menu. When i have already logged in, everything is perfect, but no matter what i do, that login prompt always appears on the HDMI monitor.

Anyone know how to move this over?

edit flag offensive delete link more


My answeer still applies - try something else than gnome and GDM in this case.

covex gravatar imagecovex ( 2015-02-26 12:42:39 -0500 )edit

answered 2015-02-24 09:33:23 -0500

covex gravatar image

This would be most probably a graphics driver issue, maybe combined with Gnome. Try to boot to text console, startx if possible to something else then Gnome, try recovery mode (as suggested), try to ssh into the machine remotely. Check the logs (journalctl)! You may try to install amd proprietary driver, but for some time this is not a part of repository as they do not support wayland extension in Gnome, there are needed additional steps to enable amd catalyst proprietary driver.

edit flag offensive delete link more

answered 2015-04-02 04:05:59 -0500

I experianced a similar issue and was able to work around it by editing the OS item from the grub menu and removing the load_video option.

edit flag offensive delete link more

Question Tools


Asked: 2015-02-23 18:17:01 -0500

Seen: 5,295 times

Last updated: Feb 25 '15