Ask Your Question
2

How to improve font rendering in gnome-shell?

asked 2015-02-20 10:23:16 -0500

Classic gravatar image

updated 2015-02-24 16:45:17 -0500

Hi!

I'm using Fedora 21 with Gnome DE. I want to use gnome-shell light theme, but dark fonts on light background looks ugly. What can I do to improve shell's font rendering?

I have created /etc/fonts/local.conf file with enabled sub-pixel rendering & slight hinting, installed freetype-freeworld package from rpmfusion repo and fonts in the apps looks great, but in gnome-shell they are still ugly.

I've tried to create symlinks for 10-sub-pixel-rgb.conf file in /etc/fonts/conf.d, add Xft.lcdfilter: lcddefault to .Xresources file, but no result.

Gnome-tweak-tool settings: hinting - slight, antialiasing - rgba.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-03-16 20:15:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I decided to reflect the instructions to setup and configure subpixel font hinting as described here since there seems to be a demand for it.

I think that Fedora with Gnome deserves a nice font, and I love the tweaked font using subpixel font hinting.

I am going to list the commands to achieve the result. For more information, please read the original post.

The command xrdb -query lists your (default) settings. Nice settings (as they are used in Ubuntu) are the following ones:

  • Xft.dpi: 96
  • Xft.antialias: 1
  • Xft.hinting: 1
  • Xft.hintstyle: hintslight
  • Xft.rgba: rgb
  • Xft.lcdfilter: lcddefault

Here is what you do:

1.) For subpixel rendering you need to install freetype-freeworld (sudo dnf install freetype-freeworld) from rpmfusion.

2.) use gnome-tweak-tool to set the hintstyle to slight and anti-aliasing-mode to rGBA.

3.) Activate lcdfilter: Unfortunately, there is no GSettings key for it. You have to create a hidden .Xresource file with the Xft.lcdfilter: lcddefault setting in your home directory. Run echo "Xft.lcdfilter: lcddefault" > ~/.Xresources.

4.) Logoff and logon again, and you will see the changes. Use xrdb -query to display your settings.

Have fun with (what I think is a nicer) Gnome!

edit flag offensive delete link more
0

answered 2015-02-24 10:01:54 -0500

covex gravatar image

In my opinion the problem is, Gnome tends to set things on the fly from its own config files. Did you try the gnome-tweak-tool to set antialiasing and hinting?

edit flag offensive delete link more

Comments

Of course, i did. Gnome-shell doesn't respect this settings.

Classic gravatar imageClassic ( 2015-02-24 16:34:30 -0500 )edit

@Classic: In my opinion, these are excellent instructions and they make Gnome look really good with subpixel font hinting: http://peter.kingofcoders.com/?p=177

florian gravatar imageflorian ( 2015-03-17 17:24:18 -0500 )edit

Agreed. These instructions made a significant change in the overall appearance of my Fedora 21 / Gnome desktop.

Glenn gravatar imageGlenn ( 2015-05-06 04:49:39 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-02-20 10:23:16 -0500

Seen: 15,566 times

Last updated: Mar 19 '15