Ask Your Question
1

How to prevent Xfce session restore after login

asked 2015-02-14 16:24:55 -0500

Steve HHH gravatar image

I'm using the Fedora 21 Xfce spin, and even after turning off session restore feature in Xfce and deleting the session cache, logging in still causes the previously opened apps to open. How can I disable this feature, so each session starts afresh?

I have set the following Xfce configuration, to no avail:

  • Settings > Session and Startup > General > Automatically save session on logout (unchecked)
  • Settings > Session and Startup > Session > Clear saved sessions
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-16 22:49:18 -0500

Steve HHH gravatar image

It seems that there are actually three places to disable session restore, and I missed the third. The first two are under Xfce Settings:

  • Settings > Session and Startup > General > Automatically save session on logout
  • Settings > Session and Startup > Session > Clear saved sessions

But when you perform a log out, restart, or shutdown action, the third check-box is in the modal dialogue:

  • Save session for future logins

Ensure that that check-box is unchecked. Judging by the forum posts I've seen about the web, I'm not the only one who missed this, and hopefully this answer will save someone else a bit of time and frustration.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-02-14 16:24:55 -0500

Seen: 1,437 times

Last updated: Apr 16 '15