Ask Your Question
2

How do I enable the Media-Server in Fedora 20?

asked 2015-01-31 00:42:02 -0500

updated 2016-03-13 08:17:32 -0500

Fedora's default Desktop Environment is GNOME. In Settings -> Sharing there's an option to enable, as the name suggests, sharing local user's media files across the network. GNOME's Media-Server

However, this doesn't seem to work as intended; as I'm not able to see the media server on available on the network from any other PCs and/or devices! Am I missing something here? What additional options or configuration changes are needed? This is a very useful feature with tremendous potential; its implementation, however, is flawed.

As I understand it, the media server package is rygel. There is very little (or bad/outdated) documentation available for this program. It's especially troubling since, as I stated already, GNOME is the default Desktop Environment in Fedora! The Rygel program has a lot of potential, especially as it is integrated into the GNOME Desktop Environment. The lack of documentation prevents users and system administrators from troubleshooting, configuring, and adapting rygel to the new Linux environment with seemingly unsupported software (systemd, polkit,etc.).

Update: There is ongoing development that can be tracked on GitHub or at Gnome's git repos

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-03-13 09:00:52 -0500

The Rygel Startup site at GNOME has a few useful comments and links to relevant pages. The project seems to be actively developed, which is very encouraging.

https://github.com/GNOME/rygel/tree/m... has an Example rygel.service file for use with systemd.

[Unit]
Description=Rygel DLNA server
After=syslog.target

[Service]
User=rygel
Group=rygel
ExecStart=/usr/bin/rygel
# ExecStart=/usr/bin/wrap-dbus /usr/bin/rygel

[Install]
WantedBy=multi-user.target
edit flag offensive delete link more

Comments

1

we should this service to the package .

sergiomb gravatar imagesergiomb ( 2016-03-13 23:33:12 -0500 )edit
0

answered 2017-01-03 22:05:59 -0500

SteveEbey73701 gravatar image

You probably need to open ports in the firewall. I run minidlna and had to open posts, before my tv saw the server.

edit flag offensive delete link more

Comments

No. The firewall was the first thing I had checked. The question pertains to a problem that was apparent at the time of writing. As I mentioned in my answer, though, the development of the relevant package(s) resolved the issue shortly thereafter. Thanks anyway

ILMostro gravatar imageILMostro ( 2017-03-20 22:08:33 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-01-31 00:42:02 -0500

Seen: 3,497 times

Last updated: Jan 03 '17