Ask Your Question
0

Why is Firefox disabling my flash-player and seeing it as an older one?

asked 2015-01-29 14:50:25 -0500

updated 2015-01-29 16:52:22 -0500

Hi, I use Fedora 21 on my laptop, and yesterday Firefox(updated) informed me that it was disabling the flash-plugin because it was outdated, the version it see's it as is much older than I have installed. Anyone else having this? Do you know how to fix?

My system has all updates.

Here is my flash:

[root@Host ~]# yum list flash-plugin
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * fedora: ftp.uni-bayreuth.de
 * rpmfusion-free: mirror.proserve.nl
 * rpmfusion-free-updates: mirror.proserve.nl
 * rpmfusion-nonfree: mirror.proserve.nl
 * rpmfusion-nonfree-updates: mirror.proserve.nl
 * updates: ftp.uni-bayreuth.de
Installed Packages
flash-plugin.x86_64                 11.2.202.440-release                  @adobe-linux-x86_64

Here is my Firefox:

[root@Host ~]# yum list firefox
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * fedora: ftp.uni-bayreuth.de
 * rpmfusion-free: mirror.proserve.nl
 * rpmfusion-free-updates: mirror.proserve.nl
 * rpmfusion-nonfree: mirror.proserve.nl
 * rpmfusion-nonfree-updates: mirror.proserve.nl
 * updates: ftp.uni-bayreuth.de
Installed Packages
firefox.x86_64                              35.0-6.fc21                              @updates

EDIT: I just found this.

edit retag flag offensive close merge delete

Comments

It seems that there have been a lot of exploits through the flash plugin recently..... hope there will be an update soon!

somethingSomething gravatar imagesomethingSomething ( 2015-01-31 23:11:13 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-01-29 17:05:57 -0500

sideburns gravatar image

Close firefox, open a terminal and do this:

cd ~/.mozilla/firefox
ls

You will see several items, including a directory with a name that starts with a bunch of junk and ends with .default, which I'll refer to as [hash].default, as the junk is a hash that firefox uses as an identifier. Then:

cd [hash].default
rm pluginreg.dat

Close the terminal and restart firefox. This will force it to rebuild the file with the correct data.

edit flag offensive delete link more

Comments

@sideburns Thanks I'm sure this is good stuff and I have done it, but it didn't fix it, now Firefox displays the right version but still say's it's an vulnerable plugin, still it's the latest flash-player so not much more I can do.

somethingSomething gravatar imagesomethingSomething ( 2015-01-29 17:24:09 -0500 )edit

Could be because of this

somethingSomething gravatar imagesomethingSomething ( 2015-01-29 17:45:36 -0500 )edit
0

answered 2015-02-15 11:44:03 -0500

I too was having this problem. Followed these instructions but to no avail. It kept failing when I tried to install from the Adobe website. I tried sudo yum update firefox....still no joy.

after that I tried sudo yum update flash-plugin (a bit of a punt)....

and it worked!

edit flag offensive delete link more
0

answered 2015-01-29 17:30:06 -0500

deusdara gravatar image

Hi

Updating Flash

To check if your installation of Flash is up to date, visit Mozilla's Plugin Check page. If it says that Flash is outdated, you can update Flash by downloading and installing the latest version from Adobe.

https://support.mozilla.org/en-US/kb/keep-flash-up-to-date-and-troubleshoot-problems#w_updating-flash

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-01-29 14:50:25 -0500

Seen: 2,722 times

Last updated: Feb 15 '15