Ask Your Question
0

Accidentally set bash profile to speak everything typed in terminal...how do I go back and edit it when any command I type is spoken instead of executed?

asked 2015-01-27 07:15:29 -0600

peanutbutterz gravatar image

updated 2015-01-27 07:24:00 -0600

I am a true beginner with Linux and fedora. I was fooling around and got the terminal to open with typing out and speaking "Welcome, myName" and then the fortune | xcowsay command. So I was trying to get it to open with speaking the fortune as well, so I used espeak | fortune | xcowsay and now the terminal only speaks everything I type, I can't even go back into bashrc to edit it... How do I go back and change it when every command I type is actually spoken instead of executed? Sorry if this is a dumb question, I just don't know what to do!

This is what the shell start up file commands looked like:

 echo "Welcome, myName!"
 espeak "Welcome, myName"
 espeak | fortune | xcowsay

EDIT: Just kidding, I figured it out...sorry. I just have to press Ctrl + C in the terminal... Now my question is if there's any way I can command it to speak the fortune from xcowsay?!

edit retag flag offensive close merge delete

Comments

If you're asking a different question than the one in the title, consider editing the whole question, including the title, so people know what you're looking for help with. FWIW, it's a question that can be addressed with marginal bash scripting skills, and I think you'll figure out an answer as you gain a little experience in any case.

randomuser gravatar imagerandomuser ( 2015-01-27 08:36:21 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-27 11:08:07 -0600

davidva gravatar image
cp -f /etc/bashrc ~/.bashrc

source ~/.bashrc

Close session, and test again...

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-01-27 07:15:29 -0600

Seen: 409 times

Last updated: Jan 27 '15