Ask Your Question
0

No sound in xfce, works fine in gnome

asked 2015-01-23 19:07:18 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi

I have searched a lot but I have not managed to find a solution for this.

I just installed Fedora Workstation 21 64-Bit that comes with gnome and installed all the updates from the update repository. I also installed xfce using yum install @xfce.

The sound works fine using gnome and if log out and switch to xfce the sound also works fine, but if I log directly into xfce after boot the sound is not working.

I installed xfce4-volumed that also provides xfce4-mixer but nothing changed. The xfce4-mixer volme control for the xfce panel is not muted but if the if I right click and choose "Run Audio Mixer" the mixer won't start, the volume keys on the keyboard doesn't do anything either and if I run alsamixer at the command line I don't get any output.

I also installed pavumixer but when when I run it never manages to connect to Pulse Audio.

Just tell me if you want me to post any logs or config-files, I don't have much experience with sound in linux and I am not really sure what to post and what to not.

I really appreciate any help you can provide!

Edit: Running lspci for some reason causes the sound to work again.

Update

My chipset is Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04) according to lspci.

/proc/asound/version says I have ALSA driver version k3.17.8-300.fc21.x86_64 but /dev/sndstat does not exist. I've got alsa-lib, alsa-plugins-pulseaudio, alsa-utils, alsa-firmware and alsa-tools-firmware installed.

Running alsamixer when the sound isn't working outputs the message that it cannot connect to Pulse Audio no matter if I run it as root or not.

Again, running lspci for some reason causes everything to work normally and the volume can be adjusted using alsamixer. I've also discovered that logging out and shutting down takes really long when the sound isn't working.

Output of "dmesg | grep hda" in case it may provide any help:

[    3.910459] pci 0000:01:00.0: optimus capabilities: enabled, status dynamic power, hda bios codec supported
[    7.356284] snd_hda_intel 0000:00:1b.0: irq 33 for MSI/MSI-X
[    7.356984] snd_hda_intel 0000:01:00.1: Disabling MSI
[    7.356991] snd_hda_intel 0000:01:00.1: Handle VGA-switcheroo audio client
[    7.376163] sound hdaudioC0D0: autoconfig: line_outs=1 (0xa/0x0/0x0/0x0/0x0) type:line
[    7.376167] sound hdaudioC0D0:    speaker_outs=1 (0xd/0x0/0x0/0x0/0x0)
[    7.376168] sound hdaudioC0D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
[    7.376169] sound hdaudioC0D0:    mono: mono_out=0x0
[    7.376170] sound hdaudioC0D0:    inputs:
[    7.376171] sound hdaudioC0D0:      Mic=0xc
[    7.376172] sound hdaudioC0D0:      Internal Mic=0x11
[    7.376173] sound hdaudioC0D0:      Line=0xf
[   11.737506] snd_hda_intel 0000:01:00.1: Disabling via VGA-switcheroo
[   11.860062] snd_hda_intel 0000:01:00.1: Cannot lock devices!
[   16.221768] snd_hda_intel 0000:01:00.1: Enabling via VGA-switcheroo
[   18.367506] sound hdaudioC1D0: hda-codec: out of range cmd 0:6 ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-30 06:04:44 -0500

I had a similar problem while using awesome-wm without a display manager. I resolved the issue by adding my username to the groups audio, pulse, and pulse-access groups:

# usermod -a -G audio myusername
# usermod -a -G pulse myusername
# usermod -a -G pulse-access myusername

I made sure to jot it down for future reference on my blog-page; feel free to take a look in case I missed something. The Arch Wiki has some more details on pulse-audio.

edit flag offensive delete link more

Comments

1

Thank you, this worked! I also needed set start-pulseaudio-x11 to run at login which you wrote about in your blogpost.

HenrikL gravatar imageHenrikL ( 2015-01-30 13:25:52 -0500 )edit
0

answered 2015-01-24 10:01:24 -0500

deusdara gravatar image

Hi

Step Zero: Sound Card

Do you know which sound card/chip is installed on your system? No? Go dig out your motherboard box, or computer manual and identify your sound card/chip. You need this before you can fix your problem. Some systems don't have a plug-in card. The sound card is on-board chip on the motherboard.

Go find it.

Once you have the name/make/model of your sound card/chip, you can start.

Step One: ALSA Is alsa installed on your system?

cat /proc/asound/version

cat /dev/sndstat

Displays ALSA version. Confirms ALSA installed. If not install it.

Step Two: Alsamixer

Check sound levels using alsamixer. Open alsamixer and check volume levels. The majority of sound problems relate to volume levels too low or mute set. Run alsamixer as root:

alsamixer

Use Page Up and Page Down arrow keys to increase/decrease volume levels. Increase volume levels at least 50% or halfway. Ensure Master level is turned up. Ensure PCM is turned up. Also turn up Front level. This applies if your card is multi-channel, 5.1 or similar.

Note If the volume levels are set high and you still have no sound, check if any channel is marked [MM] It means the channel is muted. Press 'M' on the keyboard to un-mute the sound on that channel. Press 'M' again to toggle the setting.

Make sure 'Master', 'PCM' and 'Front' are all un-muted and volume turned up. Press 'Esc' to exit. You can run a simple sound test using 'speaker-test' to check for sound output.

edit flag offensive delete link more

Comments

Thank you very much for the answer, I updated my question.

HenrikL gravatar imageHenrikL ( 2015-01-24 14:20:25 -0500 )edit
0

answered 2015-01-29 09:19:30 -0500

Hi, have the same problem on Arch.

I may have solved my issue by removing the power_save=1 option I had enabled in the snd-hda-intel module. This is the first reboot after removing it and it is working fine, unless I did not trigger the race condition by chance.

I guess I'll find out in the next few days if that's the case...

edit flag offensive delete link more

Comments

Interesting, power_save is set to 0 on my system.

HenrikL gravatar imageHenrikL ( 2015-01-30 04:26:47 -0500 )edit

Question Tools

Stats

Asked: 2015-01-23 19:07:18 -0500

Seen: 9,265 times

Last updated: Jan 30 '15