Ask Your Question
0

how to mount raid1 /home

asked 2015-01-23 08:56:56 -0500

Wylbur gravatar image

I am migrating from SUSE 13.2 64bit to F21. So the install of F21 is done, and now I need to mount the /home partitions (RAID1 software).

Well, I can't seem to get mdadm to cooperate. I can get it to recognize that the partitions are there (sda4 & sdb4).

How do I get /dev/md0 recognized/created so that I can update fstab?

I've spend over an hour working through this with the KDE Live DVD and with the installed F21. I just can't seem to get mdadm to handle this. I have tried the following:

mdadm --assemble /dev/md0 /dev/sda4 /dev/sdb4

and it returned:

mdadm: /dev/sda4 is busy - skipping mdadm: Found some drive for an array that is already active: /dev/md/linux:0

When I issue mount, I do not see anything that represents those two partitions.

And yes, as soon as I get it all smoothed out, I will change fstab to use UUID...

edit retag flag offensive close merge delete

Comments

What does cat /proc/mdstat report ?

gjanssens gravatar imagegjanssens ( 2015-01-23 14:35:18 -0500 )edit

Personalities : [raid1] md127 : active (auto-read-only) raid1 sda4[0] 408420356 blocks super 1.0 [2/1] [U_] bitmap: 390/390 pages [1560KB], 512KB chunk

unused devices: <none></none>

Wylbur gravatar imageWylbur ( 2015-01-23 15:33:25 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-23 15:53:02 -0500

Wylbur gravatar image

I found it.

The cat /proc/mdstat gave me the answer.

This is what I put into fstab:

/dev/md127 /home ext3 defaults,nofail 1 2

And then

mount -a

mount

And that shows it correctly mounted and Dolphin (File Manager) shows the mount took, and the directory, /home is now correctly populated.

edit flag offensive delete link more
0

answered 2015-01-23 15:53:19 -0500

gjanssens gravatar image

Based on your comment reply, it looks like mdadm already discovered that /dev/sda4 is one side of a RAID1 mirror and automatically created device md127. That's why it refuses to create /dev/md0 using the same disk.

You can choose to keep md127 and hot-add your /dev/sdb4 to it to complete your raid1 mirror.

If you insist the raid partition should be /dev/md0, you can stop /dev/md127 and reassemble /dev/md0 based on /dev/sda4 and /dev/sdb4.

To force your system from also doing this on the next boot you can create /etc/mdadm.conf with this contents:

ARRAY /dev/md0 level=raid1 num-devices=2 UUID=a3b8866f:3ef1aecd:bbb3bc07:9a2f57ef

You should change the UUID to represent your raid partition of course.

mdadm --detail /dev/md0

will tell you what the UUID is for your raid partition (after you have assembled /dev/md0!)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-01-23 08:56:56 -0500

Seen: 2,039 times

Last updated: Jan 23 '15