Can't change resolution with xrandr

asked 2015-01-15 05:24:27 -0500

nontenda gravatar image

updated 2015-04-21 09:08:40 -0500

mether gravatar image

I got an ASUS laptop and Fedora has not detected the full hd resolution. xrandr returns :

eDP1 connected primary 3200x1800+0+0 (normal left inverted
right x axis y axis) 293mm x 165mm
3200x1800     60.00*+  48.01      
2048x1536     60.00
1920x1440     60.00
1856x1392     60.01
1792x1344     60.01
1600x1200    60.00
1400x1050     59.98
1280x1024     60.02
1280x960       60.00
...(lower resolution)

But 3200x1800 is definitiley too high si I made a

cvt 1920 1080 60.00
xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode eDP1 1920x1080_60.00

xrandr --output eDP1 --mode 1920x1080_60.00

The screen goes black and returns to 3200x1800 (no errors are shown in console).

How can I force my screen to be in 1920x1080 res ?

edit retag flag offensive close merge delete

Comments

3200x1800 is working. Why use a non-native resolution with a completely different aspect ratio?

randomuser gravatar imagerandomuser ( 2015-01-15 08:46:23 -0500 )edit

Do any of the other existing modes work? I'd try bouncing down to 1920x1440. If that works, at least we have narrowed the scope of the issue to the new mode you've constructed.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-01-15 09:58:30 -0500 )edit

It used to work for me this way. Recently i've been having the same problem of yours and I still couldn't find the solution. :p

spagnollo gravatar imagespagnollo ( 2015-02-22 08:38:57 -0500 )edit

I would suggest using your desktop environment and application's DPI scaling features instead of changing the resolution, if the goal is to have more readable text and such. However, noone has actually stated what problem they are trying to solve, only reported issues with the methods used to solve the problem.

randomuser gravatar imagerandomuser ( 2015-02-22 16:55:53 -0500 )edit