Ask Your Question

VirtualBox and kernel-3.17.8-300

asked 2015-01-15 04:43:29 -0500

9734 gravatar image

updated 2015-01-15 20:06:36 -0500

mether gravatar image

Unfortunately, I am not able to install VirtualBox (kmod) on kernel-3.17.8-300, nor is the Kernel kernel-3.17.7-300 somewhere available (was it ever released??).

[root@batmans_cave]# yum install VirtualBox --enablerepo=rpmfusion-free-updates-testing
Loaded plugins: langpacks
rpmfusion-free-updates-testing                                      | 2.7 kB  00:00:00     
rpmfusion-free-updates-testing/21/x86_64/primary_db                 | 8.3 kB  00:00:00     
Resolving Dependencies


--> Processing Dependency: kernel-uname-r = 3.17.7-300.fc21.x86_64 for package: kmod-VirtualBox-3.17.7-300.fc21.x86_64-4.3.20-2.fc21.2.x86_64
--> Finished Dependency Resolution
Error: Package: kmod-VirtualBox-3.17.7-300.fc21.x86_64-4.3.20-2.fc21.2.x86_64 (rpmfusion-free-updates)
           Requires: kernel-uname-r = 3.17.7-300.fc21.x86_64
           Installed: kernel-core-3.17.4-302.fc21.x86_64 (@updates)
               kernel-uname-r = 3.17.4-302.fc21.x86_64
           Installed: kernel-core-3.17.6-300.fc21.x86_64 (@updates)
               kernel-uname-r = 3.17.6-300.fc21.x86_64
           Installed: kernel-core-3.17.8-300.fc21.x86_64 (@updates)
               kernel-uname-r = 3.17.8-300.fc21.x86_64
           Available: kernel-core-3.17.4-301.fc21.x86_64 (fedora)
               kernel-uname-r = 3.17.4-301.fc21.x86_64
           Available: kernel-debug-core-3.17.4-301.fc21.x86_64 (fedora)
               kernel-uname-r = 3.17.4-301.fc21.x86_64+debug
           Available: kernel-debug-core-3.17.8-300.fc21.x86_64 (updates)
               kernel-uname-r = 3.17.8-300.fc21.x86_64+debug
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@batmans_cave]# wtf
bash: wtf: command not found...

I am frustrated. I am awaiting this update since one week!

What is a common solution to install VirtualBox without akmod?

edit retag flag offensive close merge delete


@cept0 FYI, Ask Fedora is moderated and your posts have to be approved. It might sometimes take a bit of time, but there's no need to post again.

randomuser gravatar imagerandomuser ( 2015-01-15 08:45:15 -0500 )edit

From what I can see, this post was submitted eight times, with the exact same wording within less than an hour. Patience is a virtue that you need to learn.

sideburns gravatar imagesideburns ( 2015-01-15 14:22:33 -0500 )edit

here we are, it is 20th of january and the problem is up and running.

rich1974 gravatar imagerich1974 ( 2015-01-20 13:49:10 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted

answered 2015-01-15 05:28:07 -0500

cobra gravatar image

According to the Fedora Packages system the current kernel version on Fedora is 3.17.6-300.fc21. If you have that installed it should work with the package kmod-VirtualBox-3.17.6-300.fc21.x86_64 which is available in rpmfusion updates repository.

The current kernel releases for Fedora can be viewed here:

And the kmod-VirtualBox releases in rpmfusion are visible here:

Is there a particular reason you're using --enablerepo=rpmfusion-free-updates-testing? You shouldn't enable the testing repositories unless you have a direct need, or are part of the team doing tests - it can cause stuff to fail especially on dependencies.

edit flag offensive delete link more



I got the 3.17.8 kernel on Jan 12th. Looks like it came from the updates repo.

agunn gravatar imageagunn ( 2015-01-15 07:32:37 -0500 )edit

According to that packages page, it's still at 3.17.6 on the Overview tab. The Updates tab doesn't give a date for that release. Looks like the underlying problem is fixed, though.

cobra gravatar imagecobra ( 2015-01-20 15:44:52 -0500 )edit

problem does not appear to be fixed as of 24/01/15 unless updating the kernel from the updates-testing repository.

nico gravatar imagenico ( 2015-01-24 08:05:50 -0500 )edit

answered 2015-01-20 06:43:47 -0500

sergiomb gravatar image

Hi you have done things correctly , when this things happens , I believe that happened :) , contact rpmfusion to fix his mistake , by opening a bug on rpmfusion

Example: (you may reopen it)

because maintainers get an alarm and will fix things soon . I see by logs [1], that should be available now .



  • Thu Jan 15 2015 Nicolas Chauvet - 10:21-7
  • rebuild for kernel 3.18.2-200.fc21

  • Sat Jan 10 2015 Nicolas Chauvet - 10:21-6

  • rebuild for kernel 3.17.8-300.fc21
edit flag offensive delete link more


9734 gravatar image9734 ( 2015-01-21 03:03:46 -0500 )edit

answered 2015-01-15 07:32:57 -0500

agunn gravatar image

I'm having a similar issue. I received the 3.17.8 kernel on Jan 12th and VirtualBox stopped working since there is no kmod-VirtualBox-3.17-8 available.

I'm running 3.17.7 to get around the problem. Looks like it's available in the Fedora Updates repo -

edit flag offensive delete link more



Sometimes rpmfusion can take a little extra time building their kmods. Give it a couple of days and it should be straight. If you're worried that it's not been built, then you can raise a bug - I've done that a couple of times over the years for kmod-nvidia when it had been missed from the build by mistake.

cobra gravatar imagecobra ( 2015-01-15 07:37:17 -0500 )edit

22+ days are not a "little" extra time ... it sucks man

9734 gravatar image9734 ( 2015-01-21 02:53:55 -0500 )edit
9734 gravatar image9734 ( 2015-01-21 03:07:17 -0500 )edit

answered 2015-01-22 17:56:37 -0500

Using the package manager for the 3.17.8 kernel still doesn't work as of 22 January, but my workaround was to just install the rpm package directly from the virtualbox website:

su -c "yum install libpng15.x86_64"
su -c "rpm -Uhv VirtualBox-4.3-4.3.20_96996_el7-1.x86_64.rpm"

Although using yum is probably preferable, this has worked fine for me.

edit flag offensive delete link more


This solution works

suoko gravatar imagesuoko ( 2015-01-24 15:57:36 -0500 )edit

Question Tools



Asked: 2015-01-15 04:43:29 -0500

Seen: 2,231 times

Last updated: Jan 22 '15