Ask Your Question
1

F21: can I have multiple X logins on the console?

asked 2015-01-15 00:31:42 -0500

RL gravatar image

Hi,

In F21 the graphical console login is controlled by GDM 3.14, which allows users to login on console VT1. However, I'd like to setup a second graphical login screen on, for example, VT8.

The purpose is that my wife can login via the standard VT1 login screen, whereas I can do so on VT8. The switch between the two is fast (ctrl-alt F1 and ctrl-alt F8) and there's no need to use the 'switch user' thingy on the VT1 console screen.

The big questions are:

  • Is this possible?
  • If yes, where do I start to set this up?

Thank you, R.L.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2015-01-15 10:46:07 -0500

updated 2015-01-15 12:31:27 -0500

Yeah, what you're talking about is a multiseat configuration, and it's awesome. Systemd makes this possible in Fedora 21. I outline the general procedure on my blog and include a link to a detailed instruction set from Fedora 17 which is still applicable. Said general procedure is as follows:

1) Identify the seats currently defined for your system (probably just seat0).

loginctl list-seats

2) List the devices currently attached to the seats (simple if it’s just seat0)

loginctl seat-status seat0

3) Identify the devices you would like to repurpose for the new seat (seat1, in this example).

loginctl seat-status

4) Attach the devices to seat1.

loginctl attach seat0 /sys/devices/device_path_here [attach as many as are necessary for your purposes]

5) Observe success and rejoice.

The general prerequisites are sufficient hardware - you'll need two graphics adapters so that one can be assigned to each seat, and obviously you'll need two monitors, keyboards, and mice at a minimum. You can basically assign any device connected to your system to either seat, however, so you can even provide independent sound cards or other PCI/USB devices for each seat.

edit flag offensive delete link more

Comments

Just to clarify, this is for simultaneous use of two "physical" seats, not a TTY-switching thing.

randomuser gravatar imagerandomuser ( 2015-01-15 13:50:32 -0500 )edit

That is true. I kinda inferred that he desired this setup from his post, but in retrospect, it might not be what he was after.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-01-15 15:27:42 -0500 )edit

Indeed, I was not referring to 'multi-seat' setup, but to 'single-seat-multi-Xsession' setup. Until I upgraded to F21 I was always able to do:

  • One user logged on via the standard Xlogin console on VT1.
  • A second user would use ctrl-alt-F2 to switch to the text console on VT2.
  • After login in, the second user typed: "startx -- :1 vt8"

However, in F21 the startx does not work by changes made somewhere deep in the F21 system. It seems to be related to not running Xorg as root anymore, but I can't grasp the details of what actually has changed in F21. So: how to do another Xlogin in F21?

RL gravatar imageRL ( 2015-01-15 19:06:57 -0500 )edit

@bitwiseoperator - it's interesting info though, thanks :) I wasn't sure how to do this before.

randomuser gravatar imagerandomuser ( 2015-01-16 00:10:08 -0500 )edit
0

answered 2015-01-15 13:53:04 -0500

You can do something like xinit gnome-session -- :3 vt7 if you don't want to use GDM to switch sessions - although, GDM is probably doing more than simply launching gnome-session, so switching users with GDM is probably still a better approach.

edit flag offensive delete link more

Comments

That was indeed possible before F21. However, in F21 you cannot do this anymore: the console goes blank, becomes unresponsive, and renders unusable; a remote login is needed to kill the hanging Xorg program. Errors in /var/log/Xorg.3.log reveal the culprit: "[4015.487] (EE) intel(0): failed to set mode: Permission denied [13]". This seems not to be a bug, but a new F21 feature with nasty side-effects!

RL gravatar imageRL ( 2015-01-15 20:52:26 -0500 )edit

hmm... you might want to file a bug, then.

randomuser gravatar imagerandomuser ( 2015-01-16 00:05:29 -0500 )edit
0

answered 2015-01-16 06:43:28 -0500

RL gravatar image

Eventually I figured that this problem is somewhat solved on the Fedora bugzilla list:

https://bugzilla.redhat.com/show_bug.cgi?id=1078902

The crux is to add a file /etc/X11/Xwrapper.config with the content "needs_root_rights = auto".

There are still dangling problems with F21 on this topic, which are hopefully ironed out in the next release F22.

R.L.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-01-15 00:31:42 -0500

Seen: 1,128 times

Last updated: Jan 16 '15