Ask Your Question
1

Cannot transfer home files from Fedora 14 to Fedora 21

asked 2015-01-13 18:31:48 -0500

The Evil One gravatar image

I have 2 500GB WD HDDs. One of them HDD28 contains the Fedora 14 system I have been using up to now, the other HDD29 contains Fedora 21 workstation which I installed yesterday.

I attempted to transfer my home files by booting from HDD29 Fedora 21 and installing the HDD28 with the Fedora 14 system in a USB HDD dock. In the file manager it shows up as 3 partitions one of 524 MB, one of 54GB and one of 442GB. The name of the 442GB partition appears to be /dev/vg_host01/lv_home. When I click on it the file manager demands the root password and when i give this an icon for my home directory "Carl" appears and when I click on this icon a message appears:- "This location cannot be displayed. You do not have permissions necessary to view contents of "Carl" " So I open a terminal hoping that using SU and line commands may allow me to copy. I use cd to switch to directory /dev/vg_host01 and this works but when I use cd to switch to lv_home I get the message that lv_home is not a directory.

Is there a way to use SU with the file manager.

I set up the new system with the same host name host01 as the old system and set up my loginid the same on the new system as the old system. I wonder if this may be causing some kind of conflict.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-01-13 19:40:08 -0500

sideburns gravatar image

What you need is the partition's mount point, not the name of the partition in /dev. It's probably mounted under /run/media/Carl. To make sure, right-click on the icon and select Properties; you'll see the path to it under Location. Once you know that, you should be able to get there from a CLI and copy the files.

edit flag offensive delete link more

Comments

I completely agree - do this from the command line, just use the file manager to help you locate everything. When copying files like this use the -a option with 'cp', it preserves lots of permissions things, and is intended for this purpose, use:

cp -a <src> <dst>

cobra gravatar imagecobra ( 2015-01-14 05:46:07 -0500 )edit

Thank you sideburns, I will try this.

The Evil One gravatar imageThe Evil One ( 2015-01-14 08:54:03 -0500 )edit

Since you answered my question I have made some progress in transferring the files but still cannot access the transferred files. Fedora 14 gives the option when setting up a logon to choose the numeric identifier associated with a logon, that for my logon is 500, however on Fedora 21 there is no option for specifying the numeric identifier and browsing /etc/passwd shows that mine is set to 1002. I manually edited to make it 500:500 and when this resulted in inability to use the logon tried 0500:0500 with the same result inability to logon. Obviously this number must occur in other places besides the passwd file.

The Evil One gravatar imageThe Evil One ( 2015-01-17 00:27:49 -0500 )edit
1

Linux uses the numerical ID internally, not the username. Now that you've changed that in /etc/passwd, you no longer own your home directory because the numbers don't match any more. Change the numbers back, and hope that you haven't messed things up too badly.

sideburns gravatar imagesideburns ( 2015-01-17 02:38:45 -0500 )edit

Thank you sideburns. The problem I have is that I can copy the subdirectories C D & E from my Fedora 14 system either with cp -p CDE /home/Carl or cp CDE /home/Carl but then cannot access the directory /home/Car;/E/GRP01 because of lack of permissions. The exact message is:- " This location could not be displayed you do not have the permissions necessary to view the contents of GRP01." Once I discovered that the numeric identifiers for my logons differed 500 for Fedora 14 & 1002 for Fedora 21 I assumed that editing the Fedora 21 logon to match might fix things but it resulted in inability to logon at all with that id.

What I think I need is a means of replicating my logonid from Fedora 14 to Fedora 21 or a means of changing the numeric id from 1002 to 500 at all places at ...(more)

The Evil One gravatar imageThe Evil One ( 2015-01-17 04:53:04 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-01-13 18:31:48 -0500

Seen: 172 times

Last updated: Jan 13 '15