Ask Your Question

Huge amount of Tracker-WARNING log lines upon login

asked 2015-01-10 11:39:26 -0500

Phx_01 gravatar image

updated 2015-01-10 14:09:46 -0500

mether gravatar image

Whenever I log in to Fedora (GNOME session), it apparently parses through my home folder and produces a lot of log error messages as visible with "journalctl -f".

The log lines look like the ones below just with different file names each time.

Jan 10 17:20:32 <machine_host_name> gnome-session[1539]: (tracker-extract:1889): Tracker-WARNING **: Call to gst_discoverer_discover_uri() failed: Could not determine type of stream.
Jan 10 17:20:32 <machine_host_name> gnome-session[1539]: (tracker-extract:1889): Tracker-WARNING **: Task for 'file:///home/<home_folder>/Pictures/Icons/icns/Folders/AquaBlend/AquaBlend%20-%20BMP%20Folder.icns' finished with error: Could not get any metadata for uri:'file:///home/<home_folder>/Pictures/Icons/icns/Folders/AquaBlend/AquaBlend%20-%20BMP%20Folder.icns' and mime:'image/x-icns'

While everything else in this regard appears to work, error log lines have two distinct disadvantages:

  • They tell you that something is not as it should be
  • The log files could fill up the hard drive over a period of time, especially with the amount I am getting each time.

Does somebody know what this error is about and hint me into the right direction of getting it corrected, please?

edit retag flag offensive close merge delete


  1. Tracker is reporting that it can't find metadata for some of your files. This is harmless; I think you'll be OK without your icons being nicely indexed.
  2. The log files will not fill up your hard drive. journald is designed to not do that.
randomuser gravatar imagerandomuser ( 2015-01-11 11:07:08 -0500 )edit

I am relieved that my hard drive will not end up reporting a good portion being used by those logs. And yes, I am not concerned about icons not being indexed or shown in Nautilus as a preview, etc. Since this is not an error but a warning report, I understand that it is not a critical or system-dependent message. Still, especially when Tracker tries to index something, it should be in the Tracker database by now that those files cannot be deciphered instead of retrying on each system start for the same files. The file has not changed since the last reboot. ;-)

Phx_01 gravatar imagePhx_01 ( 2015-01-12 14:19:58 -0500 )edit

Depending on how journald is configured (specifically journal file size and log rotation settings), it can actually be filled up to a large size, and slow down certain actions if it gets out of control. Most distros like Fedora use sane defaults, so it's not a huge problem. Worst case is you will have your logs rotated too fast for you to inspect other entries when you have constant streams of errors. Still, best to always get rid of them somehow. Telling tracker to skip files will also save wasted disk reads/cpu cycles if you don't need them indexed and slightly speed up indexed searches.

jpeg gravatar imagejpeg ( 2015-07-24 02:08:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-07-24 02:06:49 -0500

jpeg gravatar image

updated 2015-07-24 03:39:11 -0500

I am not sure what is wrong with the metadata from that output, but if you just want to stop the error messages, it's easiest to use the package called tracker-preferences. It can be launched from a terminal using the command of the same name.

With that program, you can choose to make tracker ignore specific directories when indexing, or you can exclude file types using * as a wildcard, for example *.jpg to exclude jpeg files from indexing. That will at least stop the error messages from filling up your journal needlessly.

Alternatively, you can exclude files/directories by editing your dconf with either a terminal or a GUI program, and also change various other settings for tracker. If you use the program dconf-editor, you can navigate to org.freedesktop.tracker and change settings there. As always, be careful messing with settings that you don't understand, especially with dconf. There are many more settings possible using dconf compared with tracker-preferences though, so perhaps you would find something else useful for this problem there.

edit flag offensive delete link more


There is no package "tracker-preferences" on Fedora 28

acyclik gravatar imageacyclik ( 2018-08-03 19:13:10 -0500 )edit

Question Tools

1 follower


Asked: 2015-01-10 11:39:26 -0500

Seen: 2,129 times

Last updated: Jul 24 '15