Ask Your Question
1

NetworkManager disable IPv6

asked 2015-01-04 10:58:52 -0500

firefexx gravatar image

When I edit the settings for a wifi network in NetworkManager, switching off IPv6 seems to have no effect.

In the settings, there is this blue toggle button, I switched off for IPv6. Before connecting to the network, ifconfig shows neither an IPv4 nor an IPv6 addess. Fine so far...

Now I connect to the network, and ifconfig shows an IPv4 as well as an IPv6 (link local) address. When observing the traffic via Wireshark, I see outgoing ICMPv6 packets from my machine.

My question is now: Why?

Is this a bug oder didn't I understand the toggle button's functionality correctly?

Fedora 21, NetworkManager 0.9.10.0

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-01-05 03:59:15 -0500

cobra gravatar image

It's a long-standing issue on Fedora, there is a bug report for it here: https://bugzilla.redhat.com/show_bug.cgi?id=982740

If you want to force IPv6 to off for your system, you can probably still blacklist the module:

http://www.g-loaded.eu/2008/05/12/how-to-disable-ipv6-in-fedora-and-centos/

Or by preventing the module loading:

http://forums.fedoraforum.org/showpost.php?p=1561370&postcount=3

If you do this successfully, don't forget to turn off the ipv6tables module if that's running.

edit flag offensive delete link more

Comments

thanks. Too bad that this bug isn't fixed yet.

firefexx gravatar imagefirefexx ( 2015-01-10 04:23:24 -0500 )edit

Question Tools

Stats

Asked: 2015-01-04 10:58:52 -0500

Seen: 5,322 times

Last updated: Jan 05 '15