Ask Your Question
0

Vino-server always prompts remote-access and I don't want it! What can I do?

asked 2014-12-25 18:52:13 -0500

q2dg gravatar image

If a set "prompt-enabled" and "notify-on-connect" values to false (they are inside /org/gnome/desktop/remote-access key inside dconf), "prompt-enabled" is automagically resetted to true (it doesn't matter if I change via dconf-editor or editing schemas.xml file, it's the same).

I only want to access silently to another machine, but in Fedora 21 it seems impossible. Has someone got it?

Thanks!

P.D: gnome-control-center sharing' options sucks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-27 18:58:00 -0500

efgtest gravatar image

updated 2014-12-29 19:51:03 -0500

answer: 3 ways:

1: From the desktop: Go to the bottom with your mouse-pointer, L-click hold and move it "up". A notification bar will appear. click on the icon located at the left corner. a pull-up window will appear select "Notification Settings" and go to "Desktop Sharing" and turn the options "OFF"

2: click on the ON/OFF button (R-up Corner) a pull down window will appear. (L-bottom icon is "Settings" ) click on that, a window will open (ALL SETTINGS) go to "Notifications Settings" and select "Notifications" - >Desktop Sharing. and turn the options "OFF"

3:Activities (L-Top Corner)-> Show Applications (L-Bottom L-side menu) ->Settings-Notifications->Desktop Sharing and turn the options "OFF"

Now you can connect and spy..I mean monitor without any pop notifications appears. Cheers.

30-12-2014: Black screen:

It does not hang. It is just waiting for confirmation from the remote server.(Just disconnect if necessary) Even if everything is turned "OFF" You will still receive a notification to confirm access. (move the mouse Activities corner and "1 new message" will appear in the middle- bottom screen). Click on the message then see "R-corner". You can also use a password to access the remote server. This way you won't have to wait for confirmation. to activate the password go to: Activities->show applications->settings->Screen sharing>"Required a password"

edit flag offensive delete link more

Comments

Yes! You were right!!! Thanks!

But now another strange thing happens: if I remove notifications as you say, when I try to connect from the client (I use Vinagre in F21) I only can see a black screen although I see in server (I use F21 too) that a connection has been made thanks to netstat -patun command.

If I restore notifications, I've seen that this black screen is shown when client is connected to server but the user in the server hasn't yet accepted the connection. So I deduce that disabling notifications, client hangs expecting a confirmation that is never clicked.

Can this be solved?

q2dg gravatar imageq2dg ( 2014-12-29 17:48:40 -0500 )edit

YES!! Your were right again!! Thanks a lot!!!!

Now I understand why there is a radiobutton instead a checkbutton in gnome-control-center sharing ...there are two options mutually exclusive: or request access (-->notifications should be enabled) or use a password (-->notifications can be disabled). Well, a little messy, but...finally works. Thanks!!

q2dg gravatar imageq2dg ( 2014-12-30 12:41:37 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-12-25 18:52:13 -0500

Seen: 1,422 times

Last updated: Dec 29 '14