Ask Your Question
0

How to install AMD proprietary Driver on Fedora 21

asked 2014-12-22 16:17:29 -0500

khamm gravatar image

updated 2014-12-22 17:34:48 -0500

mether gravatar image

Hello everybody, I got a Ati HD 5770 graphics card in my Computer. When i was running Ubuntu with the proprietary Ati drivers it preformed very well while staying very cool and quiet. Now that i installed Fedora the Idle temperature is at 50° and even hotter/louder when i watch a HD video. I find that very disturbing so i wanted to install the proprietary driver and look how the card behaves with some better drivers. Unfortunately i couldn't find any advice how it could be possible to get the drivers running on fedora 21. Even worse on some sites they wrote it is not possible to install it on fedora < 19 at all. Could somebody please tell me if it works and if yes how ? Thanks in advance.

Ps: I allready tried to install the 14.12 omega driver. System crashed after reboot with a Blackscreen.

edit retag flag offensive close merge delete

Comments

4 Answers

Sort by » oldest newest most voted
1

answered 2015-01-17 14:06:51 -0500

butlerccreltub gravatar image
edit flag offensive delete link more
0

answered 2015-05-19 05:36:53 -0500

Try this instruction:

http://wiki.cchtml.com/index.php/Fedo...

or this one:

http://ilevex.eu/post/106904892091/ho...

I need to try either one of them myself as I want to convert my dad's computer from Ubuntu 14.04 with Unity to Fedora with Gnome 3 but I'm quite confident it'll work.

edit flag offensive delete link more
0

answered 2015-03-30 18:15:11 -0500

I got the thing compiling on Fedora 21. But no luck:

[ernest@cray-firebird fglrx-14.20]$ diff -r fglrx-install.v8wglu/ fglrx-install.modified/
Only in fglrx-install.modified/: ATI_STATUS
diff -r fglrx-install.v8wglu/common/lib/modules/fglrx/build_mod/firegl_public.c fglrx-install.modified/common/lib/modules/fglrx/build_mod/firegl_public.c
1786a1787,1790
> /* ERNEST */
> #if LINUX_VERSION_CODE > KERNEL_VERSION(3,17,0)
>     return __kuid_val(current_euid());
> #else
1787a1792
> #endif
4807c4812,4816
< 
---
> #if LINUX_VERSION_CODE > KERNEL_VERSION(3,17,0)
> /* ERNEST */
>     orig_level = *this_cpu_ptr(&kasExecutionLevel);
>     *this_cpu_ptr(&kasExecutionLevel) = level;
> #else
4809a4819
> #endif
4820a4831,4834
> #if LINUX_VERSION_CODE > KERNEL_VERSION(3,17,0)
> /* ERNEST */
>     return *this_cpu_ptr(&kasExecutionLevel);
> #else
4821a4836
> #endif
diff -r fglrx-install.v8wglu/common/lib/modules/fglrx/build_mod/kcl_acpi.c fglrx-install.modified/common/lib/modules/fglrx/build_mod/kcl_acpi.c
843c843,848
<          tdev->flags.no_hotplug = true;
---
> #if LINUX_VERSION_CODE < KERNEL_VERSION(3,17,0)
>  tdev->flags.no_hotplug = true;
> #else
>  pdev->ignore_hotplug = true;
> #endif
> 
Only in fglrx-install.modified/setup.data: install_gtk.xml
Only in fglrx-install.modified/setup.data: install_txt.xml
Only in fglrx-install.modified/setup.data: install.xml
Only in fglrx-install.modified/setup.data: package.xml
diff -r fglrx-install.v8wglu/setup.data/setup.glade fglrx-install.modified/setup.data/setup.glade
1340c1340
< stored in ${ATI_LOG}.
---
> stored in /usr/share/ati.
1834c1834
< The log file has been stored in ${ATI_LOG}.
---
> The log file has been stored in /usr/share/ati.
Only in fglrx-install.modified/setup.data: setup.xml
Only in fglrx-install.modified/: usr
edit flag offensive delete link more
0

answered 2015-05-20 12:19:31 -0500

fkholmukhamedov gravatar image

updated 2015-05-20 12:34:21 -0500

Do not try. I tried and broke X.org. Then I had to reinstall system. I installed Ubuntu and proprietary drivers. But I didn't feel any sufficient difference between proprietary and open-source drivers. So I installed Fedora again.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-12-22 16:17:29 -0500

Seen: 12,605 times

Last updated: May 20 '15