Ask Your Question
1

Bumblebee not working - Fedora 21

asked 2014-12-17 12:04:20 -0500

george_____t gravatar image

updated 2014-12-17 14:32:05 -0500

Installed exactly as described here: http://fedoraproject.org/wiki/Bumblebee

Everything seemed to install fine, but when I try to use optirun I get:

[ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 3551.994070] [ERROR]Could not connect to bumblebee daemon - is it running?

And trying to run bumblebeed (the daemon) manually gives:

modprobe: FATAL: Module bbswitch not found.
[ 6181.985709] [ERROR]Module bbswitch could not be loaded (timeout?)
[ 6181.985737] [WARN]No switching method available. The dedicated card will always be on.
[ 6181.988110] [ERROR]Module 'nvidia' is not found.

But bbswitch and nvidia are both installed, so I don't know why this is happening.

Also, in System Details, Graphics is listed as "Intel Haswell Mobile", although judging by games performance and battery life I'm fairly sure my Nvidia card is always on.

P.S. My Linux experience currently totals one week, so any help, however seemingly obvious, is greatly appreciated.

systemctl status bumblebeed.service -l
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: activating (auto-restart) (Result: exit-code) since Wed 2014-12-17 20:20:56 GMT; 44s ago
  Process: 3273 ExecStart=/usr/sbin/bumblebeed (code=exited, status=1/FAILURE)
 Main PID: 3273 (code=exited, status=1/FAILURE)

Dec 17 20:20:56 localhost.localdomain systemd[1]: bumblebeed.service: main process exited, code=exited, status=1/FAILURE
Dec 17 20:20:56 localhost.localdomain systemd[1]: Unit bumblebeed.service entered failed state.
Dec 17 20:20:56 localhost.localdomain systemd[1]: bumblebeed.service failed. 
systemctl status bumblebee-nvidia.service -l
● bumblebee-nvidia.service - Compiling NVidia Driver
   Loaded: loaded (/etc/systemd/system/bumblebee-nvidia.service; enabled)
   Active: failed (Result: exit-code) since Wed 2014-12-17 20:14:01 GMT; 10min ago
  Process: 723 ExecStart=/usr/sbin/bumblebee-nvidia (code=exited, status=1/FAILURE)
 Main PID: 723 (code=exited, status=1/FAILURE)

Dec 17 20:13:54 localhost.localdomain bumblebee-nvidia[723]: --force compile selected via /etc/sysconfig/nvidia/compile-nvidia-driver
Dec 17 20:13:54 localhost.localdomain bumblebee-nvidia[723]: Building NVIDIA video drivers: Creating directory NVIDIA-Linux-x86_64-340.46
Dec 17 20:13:55 localhost.localdomain bumblebee-nvidia[723]: Verifying archive integrity... OK
Dec 17 20:14:01 localhost.localdomain bumblebee-nvidia[723]: Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 340.46.................................................................................................................................................................................................................................
Dec 17 20:14:01 localhost.localdomain bumblebee-nvidia[723]: [FAILED]
Dec 17 20:14:01 localhost.localdomain systemd[1]: bumblebee-nvidia.service: main process exited, code=exited, status=1/FAILURE
Dec 17 20:14:01 localhost.localdomain systemd[1]: Failed to start Compiling NVidia Driver.
Dec 17 20:14:01 localhost.localdomain systemd[1]: Unit bumblebee-nvidia.service entered failed state.
Dec 17 20:14:01 localhost.localdomain systemd[1]: bumblebee-nvidia.service failed.
fpaste --sysinfo
Gathering system info..........................Uploading (15.2KiB)...
http://ur1.ca/j5gys -> http://paste.fedoraproject.org/160745/41884797
bumblebee-nvidia
--force compile selected via /etc/sysconfig/nvidia/compile-nvidia-driver
Building NVIDIA video drivers: Creating directory NVIDIA-Linux-x86_64-340.46
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 340.46.................................................................................................................................................................................................................................
                   [FAILED]
edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2014-12-17 13:48:51 -0500

This is not an answer but I am going to have to use it anyways.

  1. Due to this bug Bumblebee doesn't work with SELinux. You need to set SELinux to either disabled or in permissive more until the issues are resolved. See the docs. Basically set SELINUX=enforced to SELINUX=permissive in /etc/selinux/config. Read up on SELinux if you have doubts.

  2. Please post the output of following commands.

    systemctl status bumblebeed.service systemctl status bumblebee-nvidia.service fpaste --sysinfo

  3. Also the output of running following command in terminal.

    sudo bumblebee-nvidia

edit flag offensive delete link more

Comments

Changing SELinux to permissive didn't seem to make a difference. I've added the output of those commands to the original post.

george_____t gravatar imagegeorge_____t ( 2014-12-17 14:33:07 -0500 )edit

did you reboot after changing the SELinux settings? Reboot, make sure you installed all the packages listed in wiki and rerun bumblebee-nvidia. You can catch the maintainer of the pacakge @gsgatlin here https://github.com/Bumblebee-Project/Bumblebee/issues/153

sudhirkhanger gravatar imagesudhirkhanger ( 2014-12-17 23:24:46 -0500 )edit
0

answered 2015-03-29 19:29:43 -0500

dewwes gravatar image

Using bumblebee-nvidia and running on Kernel 3.19 bbswitch was also not found.

I tried the above solutions but it did't work until I tried the following steps:

First:

sudo dkms add -m bbswitch -v 0.8.0

it said that was already there, so

sudo dkms install -m bbswitch -v 0.8.0

and finally

sudo service bumblebeed restart

And now it works.

edit flag offensive delete link more
0

answered 2014-12-22 10:38:41 -0500

In addition to the selinux issue, you might have missed the first instruction to "Install Dependencies", that would explain the failed nvidia module build. Go back to Fedora Bumblebee and double check, it can't hurt to do it twice. After that look into selinux disabling, and go from there.

edit flag offensive delete link more
0

answered 2014-12-18 00:31:39 -0500

panchtatvam gravatar image

Selinux is the culprit here. You need to turn it off. Best way to do it is sudo setenforce 0 You may enable is again using sudo setenforce 1

edit flag offensive delete link more

Comments

And that will be lost after the reboot. He isn't even able to build Nvidia modules. Problem might be with building of bumblebee-nvidia.

sudhirkhanger gravatar imagesudhirkhanger ( 2014-12-19 13:09:20 -0500 )edit

Indeed, it resolved my issued but problem came back at next boot. +1

Please don't downvote this answer, it is still useful...

remjg gravatar imageremjg ( 2014-12-20 03:55:54 -0500 )edit

Once I disabled selinux, this problem went away for me. I would upvote if I had enough points.

After I rebooted, it looks like the policy updated, and the problem now appears to be fixed permanently!

jrutley gravatar imagejrutley ( 2015-03-28 12:04:30 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-12-17 12:04:20 -0500

Seen: 7,157 times

Last updated: Dec 22 '14