Ask Your Question
0

why are my graphics messed up when loading the live USB Fedora 21

asked 2014-12-16 18:26:43 -0500

cubs4ever04 gravatar image

updated 2014-12-16 19:08:52 -0500

mether gravatar image

When I created my Fedora 21 Live with imagewriter on windows and then boot to it, the graphics are horrible and you can't read anything on the screen. When I use the live image in virtualbox everything is just fine.

Fedora 20 does not have this issue.

edit retag flag offensive close merge delete

Comments

Open up a terminal virtualbox and run this command: lspci | grep VGA and add the results to your question. That will tell us what type of graphics you have and help us troubleshoot this issue.

sideburns gravatar imagesideburns ( 2014-12-16 19:31:30 -0500 )edit

When I use the LIVE USB I can't read anything but managed to email the response

[liveuser@localhost ~]$ lspci | grep VGA 01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 660 Ti] (rev a1)

I have no issues with any other linux distro or even Fedora 20 for that matter.

cubs4ever042 gravatar imagecubs4ever042 ( 2014-12-18 14:51:49 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-08 20:35:27 -0500

Flavio gravatar image

I have this trouble running on oracle virtualbox. I have used the keys Ctrl + Alt + F1..F7 for restore the video and sometimes i have used the startx command.

edit flag offensive delete link more
0

answered 2014-12-18 16:50:45 -0500

sideburns gravatar image

I see that you're using nVidia graphics, which is what I suspected. At boot, select the most recent kernel, but press E to edit the entry. Find the line that reads echo 'Loading initial ramdisk ...' put the cursor at the beginning of the line and use the left arrow to back up to the end of the preceding line. (It's a long line, and this is the easiest way to get there.) Add a space and a 3 to the end of the line, then follow the on-screen instructions to boot. This should get you to a text-only command line. Log in as root, and remember that you're root because things can get messy if you don't. Once you've done that, follow the instructions at the fedora forum for installing the appropriate kmod-nvidia. Don't worry about the thread's title, as it's just as appropriate now as it was when it was first written. Once you're done, you should be able to reboot and have proper graphics. (That edit you made, btw, was only a one-time change.) Good luck, and please keep us informed!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-12-16 18:26:43 -0500

Seen: 326 times

Last updated: Dec 18 '14