Ask Your Question
0

reported bug fedora 21 + nvidia driver (geforce forum)

asked 2014-12-16 13:54:25 -0500

juliano gravatar image

I posted there

1- disabled nouveau 2- installed without problems driver 343.36 or 346.22 3- reboot 4- after login, desktop does not work......just a gray screen with the mouse running, I need run ctrl+alt+F2 and uninstall nvidia and using nouveau back

my card is GTS 450

edit retag flag offensive close merge delete

Comments

thanks for the reply but that is not My problem is that the desktop is not loaded after graphical login with the latest nvidia driver then I need run ctrl+alt+F2 for uninstall nvidia driver and use driver nouveau again I think fedora 21 is not compatible with current nvidia drivers or maybe nvidia drivers have bug

juliano gravatar imagejuliano ( 2014-12-16 14:50:37 -0500 )edit

Ahh, right. I'll go deleting my answer then, it's not needed. Is there any help you actually need with this, or are you just bringing this to our attention?

Did you try the pre-compiled driver from the rpmfusion repository, btw?

cobra gravatar imagecobra ( 2014-12-16 14:53:06 -0500 )edit

I tested with rpmfusion for fedora 21 and had the same problem...nouveau disabled .....driver nvidia is installed without errorrs but desktop is not loaded, just grey screen with mouse pointer :(

juliano gravatar imagejuliano ( 2014-12-16 14:57:55 -0500 )edit

I am stuck with the alike bug and discuss it here: https://ask.fedoraproject.org/en/question/59259/nvidia-driver-issue-with-f21/ The card is GeForce 8500 GT. I tried different akmod-nvidia versions starting with simply akmod-nvidia. http://rpmfusion.org/Howto/nVidia says I should install akmod-nvidia-340xx but yum says there is no package akmod-nvidia-340xx. Nvidia website says my version is 340.65. If I install akmod-nvidia-34* yum installs 1:343.22-4.fc21 and them don't work after reboot.

ssr gravatar imagessr ( 2014-12-16 18:10:10 -0500 )edit
juliano gravatar imagejuliano ( 2014-12-16 20:46:02 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2015-04-13 07:50:26 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

press

ctrl+alt+F2

and login with username and password. and go to root

su -
## OR ##
sudo -i

Uninstall nVidia Driver Packages

yum remove xorg-x11-drv-nvidia\* nvidia-settings nvidia-xconfig

Remove / disable nVidia drivers from kernel initramfs

## Backup old initramfs nvidia image ## 
## (this is not mandatory, but better do it if you need it later) ##
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nvidia.img

## Create new initramfs image ##
dracut /boot/initramfs-$(uname -r).img $(uname -r)

Then Reboot System

reboot
edit flag offensive delete link more
0

answered 2014-12-16 18:10:14 -0500

ssr gravatar image

Nvidia-settings is installed, but says no driver is active, run nvidia-xconfig. Nvidia-xconfig produces xorg.conf which still don't work. The most fancy part that after uninstalling nvidia drivers I don't get nouveau back and Fedora 21 3.17.6-300.fc21.x86_64 starts with software rendering. There is no xorg.conf currently. Now I am stuck with restoring nouveau. Can anyone help me with restoring nouveau whilst there is no nvidia for me?

edit flag offensive delete link more
0

answered 2015-01-23 16:36:13 -0500

Seems fedora 21, which uses wayland, will not work with nvidia proprietary modules. Did anyone tried to move from wayland to the old xorg server?

edit flag offensive delete link more

Comments

No, that's not true. I have a fresh install of Fedora 21, it's using X.org as the x server. Fedora 21 has Wayland available, but my experience of it is that you have to turn it on, not turn it off.

Having said that, of course, I'm using ATI/AMD video - I'm not sure what the requirements are for the nouveau driver for nVidia hardware.

cobra gravatar imagecobra ( 2015-01-23 16:50:15 -0500 )edit
0

answered 2015-01-13 23:31:58 -0500

dylan gravatar image

rpmfusion have now added these packages in updates-testing:

yum install akmod-nvidia-340xx.x86_64 --enablerepo=rpmfusion-nonfree-updates-testing

You may need to edit your yum repo to point to the main site:

vim /etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo

Comment out the mirrorlist and uncomment the baseurl:

baseurl=http://download1.rpmfusion.org/nonfree/fedora/updates/testing/$releasever/$basearch/

edit flag offensive delete link more
-1

answered 2014-12-18 05:08:29 -0500

ssr gravatar image

Try to download and install drivers from NVidia website! Here is the page http://www.nvidia.com/Download/index.aspx -- you can select your card, download .run file from there and run it with "sudo sh" command. You'll have to stop the X server by command "sudo init 3".

But there may be troubles! I have mixed results on 2 machines, one GeForce 8500 GT, other GeForce GT 730 and 2 monitors. There may be conflicts with nouveau and akmod, problems with restoring nouveau. But some configurations work. Hope people here advice more. We'll may be considering raising bug at nvidia forums, as juliano suggests.

edit flag offensive delete link more

Comments

drivers stable 343.36 and beta 346.22 does not work and rpmfusion akmod for fedora 21 same problem, I think we should contact the nvidia developers for new fixed driver or compatible driver for fedora 21

juliano gravatar imagejuliano ( 2014-12-18 08:09:18 -0500 )edit

For now, I have managed to get 343.22 drivers to work with GeForce GT 730, seemingly from akmod. It happened after several times adding-deleting akmod, and adding-deleting NVIDIA-Linux-x86_64-340.65.run which NVidia website determines my drivers should be. According to my experience, drivers may crash unexpectedly after reboot, or after attaching 2nd display. And after that nouveau may be unable to restore. But currently I am lucky having drivers working and trying KDE5 in f21 =)

ssr gravatar imagessr ( 2014-12-18 10:17:52 -0500 )edit

This isn't the best idea. The .run installer from nvidia will overwrite system files owned by packages, which will in turn get overwritten when the packages are updated. It's a big mess that can cause unexpected problems, even if you uninstall. There are a couple sources that repackage the driver, notably negativo17 and rpmfusion repos, that solve this problem for Fedora users.

randomuser gravatar imagerandomuser ( 2014-12-18 10:22:49 -0500 )edit

ubuntu 14.10 work here with latest nvidia driver stable and beta but fedora 21 no way

juliano gravatar imagejuliano ( 2014-12-18 10:42:04 -0500 )edit
juliano gravatar imagejuliano ( 2014-12-18 11:29:05 -0500 )edit

Question Tools

5 followers

Stats

Asked: 2014-12-16 13:54:25 -0500

Seen: 8,253 times

Last updated: Jan 23 '15