Ask Your Question
0

How to get rid of Anki Traceback-Error?

asked 2014-12-14 17:59:22 -0500

vl_fedora gravatar image

updated 2014-12-15 06:52:42 -0500

mether gravatar image

Hey, please help me with this one. I am sort of new to Linux in general but I did not find a solution for this problem in the internet. So here it is:

I want to install anki on my computer so I did: sudo yum install anki The installing process went finde but when I try to run anki the following lines pop up:

Traceback (most recent call last): File "/usr/bin/anki", line 5, in <module> import aqt File "/usr/share/anki/aqt/__init__.py", line 32 except ImportError, e:</module>

This is pretty annoying and Im on that for two weeks now, so please help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-12-16 05:58:45 -0500

vl_fedora gravatar image

Okay folks, I've got it myself. The clue was in the last step of bugs.archlinux.org/task/37449 For Fedora you need to go into the fold, where anki is installed, then open the "runanki.txt" file and change the first line: from: #!/usr/bin/env python to: #!/usr/bin/env python2.7 now it works!

edit flag offensive delete link more

Comments

nice work! please file a bug against the anki package to report the problem to the maintainer, and everyone will have the fix.

randomuser gravatar imagerandomuser ( 2014-12-16 11:57:33 -0500 )edit

Question Tools

Stats

Asked: 2014-12-14 17:59:22 -0500

Seen: 730 times

Last updated: Dec 16 '14