Ask Your Question

DSL works on some fedoras not others

asked 2014-12-12 14:05:30 -0500

oddestNeeds gravatar image

updated 2014-12-12 16:55:24 -0500

mether gravatar image

I would describe my linux expertise as "hack".

I have two computers connected to one modem using a router. One machine has fedora 21 and connects. The other machine has fedora 20 ( 2 copies ) & fedora 21 - of which one version of fedora(20) connects, but the other two will not. Firewalld is disabled on all machines. The problem machine is a Lenovo 8810-D7U for which I also have a problem with the video driver, if there are suggestions there, I'm interested, but the main problem I am having is getting the DSL to connect.

Any suggestions on how I can diagnose the DSL connect problem, perhaps using info on the OS's that do work, would be tremendously appreciated.

Incidentally, my installation attempts have tradionally yielded two connections, one an Ethernet connection, the other the DSL. In my hacking attempts, I've removed the Ethernet connections, leaving just the DSL connections, with no change, the two OS's that have connectivity, retain it in either case. So, fedora 20 + 21 do not connect, but a previous fedora 20 does connect, and so does windows, all on the one box.


edit retag flag offensive close merge delete


Disabling the firewall on a machine directly connected to the internet is a terrible idea. Stop doing that.

randomuser gravatar imagerandomuser ( 2014-12-12 17:35:29 -0500 )edit

Desparate measures in desparate times I suppose.

However, I decided to delete and recreate the DSL file using the well-hidden nm-connection-manger and got an SELinux failure On resolve.conf, which was another bad Idea I was considering (disabling selinux). So, I'm not sure how to set up a resolve.conf file for PPOE, and nm-connection-editor should do it anyway, it seems, so anyideas on how to proceed?

oddestNeeds gravatar imageoddestNeeds ( 2014-12-12 22:24:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-12-12 23:04:43 -0500

oddestNeeds gravatar image

I was able to follow the selinux troubleshoot directions and fix the problem.

Step 1 was to permit the program to unlink resolve.conf using these instructions:

You need to change the label on /etc/resolv.conf

semanage fcontext -a -t FILE_TYPE '/etc/resolv.conf'

where FILE_TYPE is one of the following:

NetworkManager_etc_rw_t, NetworkManager_tmp_t, NetworkManager_var_lib_t, NetworkManager_var_run_t, dhcpc_state_t, dhcpc_var_run_t, dnsmasq_var_run_t, hostname_etc_t, named_cache_t, net_conf_t, pppd_var_run_t, systemd_passwd_var_run_t.

Then execute: restorecon -v '/etc/resolv.conf' ( I chose: NetworkManager_var_run_t)

sudo semanage fcontext -a -t NetworkManager_var_run_t '/etc/resolv.conf'
sudo restorecon -v '/etc/resolv.conf'

which worked.

The next problem was another selinux alert

You should report this as a bug. You can generate a local policy module to allow this access. Allow this access for now by executing:

sudo grep chronyd /var/log/audit/audit.log | audit2allow -M mypol; sudo semodule -i mypol.pp

Now I'm connected. In addition to creating the DSL network entry, Network Manager also created an unknown network with manual configuration settings. For a feel good. I've deleted the original Ethernet connection that was perhaps generated by default, and was apparently unnecessary.

Hunky dory now.

edit flag offensive delete link more


You shouldn't have to do that - and the labels you used, while functional, aren't "correct". You should use the fixfiles utility to restore the default configuration before assuming the labels are incorrect, ie fixfiles onboot;reboot. If you're getting SELInux label warnings like this, it only happens because you have somehow changed the default label for these files - usually by temporarily disabling SELinux instead of using permissive, or by mving a file, which preserves the source labelling.

randomuser gravatar imagerandomuser ( 2014-12-13 12:56:17 -0500 )edit

It was a pretty clean install, as I recall, if I had moved a file, memory escapes me. Thank you for the tip on fixfiles. However, I'm not sure which labels you are calling inccorrect, the post of the solution, s a paste from SElinux itself.

oddestNeeds gravatar imageoddestNeeds ( 2014-12-14 12:59:53 -0500 )edit

my other comment is fedora should ask for an dsl user ip user/password up-front on set-up if the unfortunate toad has as dsl line like mine, because, that means, in my case, the internet does not connect at boot, and, the location of the nm-connection-editor appears to be hidden, since, its not in setup.

For example adding a network in "Network Connections" does not provide a DSL option which you can find using nm-connection-editor.

oddestNeeds gravatar imageoddestNeeds ( 2014-12-14 13:13:34 -0500 )edit

incorrect FORUM TAGS ... yes I figured that out one .... thanks

oddestNeeds gravatar imageoddestNeeds ( 2014-12-14 13:34:15 -0500 )edit

oops labels not tags, did I mention hack?

oddestNeeds gravatar imageoddestNeeds ( 2014-12-14 13:42:15 -0500 )edit

Question Tools

1 follower


Asked: 2014-12-12 14:05:30 -0500

Seen: 187 times

Last updated: Dec 12 '14