Ask Your Question

installing kde on fedora 21

asked 2014-12-11 18:43:28 -0500

nitewalker gravatar image

updated 2015-02-13 09:57:06 -0500

mether gravatar image

I just installed fedora 21 on my laptop, but it came with Gnome and I want to use KDE, what do I have to do to download and use KDE, thanks

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted

answered 2014-12-12 04:11:48 -0500

As mentioned in the Common F21 bugs currently there is no easy way to switch from one release to another. Until the resolution of upstream bug # 1160917 you can try following.

How to install KDE Plasma Workspaces on Fedora Workstation.

yum groupinstall kde-desktop-environment --exclude fedora-release\*

Excerpt from #1160917

The Product-ization stuff has left us with a bit of a pickle regarding post-install addition of desktop groups - adding any other environment group to a Product install, or adding a Product environment group to any non-Product install.

If you install Fedora 21 and run 'yum grouplist', you will see the environment groups for all the various desktops we include - that is, you'll see "Fedora Workstation" (which is actually the environment group 'workstation-product-environment'), "KDE Plasma Workspaces" (which is actually the environment group 'kde-desktop-environment'), "Xfce Desktop" (which is actually the environment group 'xfce-desktop-environment'), and so on.

You will *not* see the *package* groups for each desktop - 'gnome-desktop', 'kde-desktop', 'xfce-desktop' and so on. None of those is marked <uservisible>true</uservisible> in comps, so they do not appear in the list unless you pass an extra parameter. - Adam Williamson

edit flag offensive delete link more


@donniezazen Thank's worked like a charm, this should be accepted as the right answer.

somethingSomething gravatar imagesomethingSomething ( 2015-02-06 23:47:37 -0500 )edit

answered 2014-12-11 23:17:01 -0500

You can simply add KDE to your system by using yum groupinstall "KDE Plasma Workspaces".

edit flag offensive delete link more



That leaves the user with all the GNOME stuff still installed, taking up disk space, cluttering the menu, and possibly running unwanted background services (such as Zeitgeist). Getting rid of GNOME after the fact is not straightforward at all.

minda gravatar imageminda ( 2014-12-12 09:11:24 -0500 )edit

Sure, but he didn't say he wanted to get rid of GNOME.

bitwiseoperator gravatar imagebitwiseoperator ( 2014-12-12 10:20:53 -0500 )edit

The desire to use KDE does not imply a desire to remove GNOME. You can have two desktop environments on your machine at once.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-03-24 08:17:57 -0500 )edit

Useless to discuss. I read this question over and over again now, and to me (but I am not a native speaker) it sounds that he wants to replace Gnome with KDE (because of the but it came with gnome and I want to use KDE. Whatever... nothing less important here.

florian gravatar imageflorian ( 2015-03-24 11:16:37 -0500 )edit

answered 2015-03-30 01:10:48 -0500

deadrat gravatar image

You may install KDE in Fedora easily by typing the following command in terminal.

sudo yum groupinstall "KDE Plasma Workspaces"

However I recommend that you download and reinstall the fedora , but this time Fedora KDE Spin. You may download The Fedora KDE Plasma Desktop Edition here. ( )

edit flag offensive delete link more

answered 2015-03-23 19:43:03 -0500

I get the same error when trying to reinstall mate-desktop-environment. In Mate, my menus disappeared after adding an automount entry to fstab - although I can't see how that would cause Mate to lose its menus. My solution was to go back to KDE, although Cinnamon seemed to install without error..

edit flag offensive delete link more

answered 2014-12-12 00:07:36 -0500

nitewalker gravatar image

tried runing command you listed, but it said would not install on system when I ran got following at end of attempt.....not sure what to do now

Processing Conflict: fedora-release-workstation-21-2.noarch conflicts fedora-release-nonproduct --> Processing Conflict: fedora-release-nonproduct-21-2.noarch conflicts fedora-release-workstation --> Finished Dependency Resolution Error: fedora-release-nonproduct conflicts with fedora-release-workstation-21-2.noarch Error: fedora-release-workstation conflicts with fedora-release-nonproduct-21-2.noarch You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

I am not sure of what I need to from what it says.

edit flag offensive delete link more



I think the easy way is clean install of Fedora 21 with KDE DE. Here link to KDE spin

minda gravatar imageminda ( 2014-12-12 09:15:59 -0500 )edit

I'm working on a resolution to this, myself. I hope anyone with any further information updates here - I'd rather figure out a simpler solution than rebuilding the whole system.

bitwiseoperator gravatar imagebitwiseoperator ( 2014-12-12 10:19:19 -0500 )edit

sudo yum group install "KDE Plasma Workspaces" --skip-broken That will let you install and skipp the package that is not for your "product".

svandenhul gravatar imagesvandenhul ( 2015-06-02 22:38:35 -0500 )edit

answered 2015-10-31 19:12:13 -0500

JerryBerry gravatar image

You need to use this command....

yum groupinstall kde-desktop-environment --exclude fedora-release*

edit flag offensive delete link more


yum is deprecated.

sudhirkhanger gravatar imagesudhirkhanger ( 2015-11-01 01:10:19 -0500 )edit

Question Tools



Asked: 2014-12-11 18:43:28 -0500

Seen: 23,880 times

Last updated: Oct 31 '15